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1 Introduction

1.1 Preface

The fieldbus configurator SyConDN is mainly based on the universal
fieldbus configurator SyConDN of

Hilscher Gesellschaft für Systemautomation mbH

Rheinstraße 78

D-65795 Hattersheim

Parts of this manual are extracted from the manual of Hilscher and
describe the functionality of SyConDN in combination with the
programming software WinPCL in System 200 of Bosch Rexroth. The
original tool of Hilscher possibly offers more features that cannot be used
in combination with System 200.

The original software was not adapted to the system and/or company
specifications.

The Bosch Rexroth AG assumes the responsibility and the support for
SyConDN and this manual.

1.2 Overview

You configure all devices with one tool. SyConDN checks the
dependencies between the devices. SyConDN only allows configurations
that make sense. In case of doubt SyConDN will give you a warning.

As for Hilscher devices, the configuration data are downloaded. For other
devices, export functions or documentation possibilities are available.

After the configuration you can print out a detailed documentation of your
fieldbus network. The details can be switched on/off. You can print a
documentation with details between the bus topology and the utmost
detail of one device.

SyConDN uses for the configuration standardized files containing
information about all features and limitations of the slave.

After the configuration you can switch SyConDN into the diagnostic mode.
You can watch all status information of Hilscher devices. Furthermore,
you can see protocol-independent information. If a slave does not operate
correctly, it will be displayed in a different color.

SyConDN is a Global Fieldbus
Configurator.

SyConDN Documents Your
Fieldbus System.

SyConDN Uses Standardized
Configuration Files.

SyConDN is a Diagnostic Tool.
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2 Important Directions for Use

2.1 Appropriate Use

Introduction
Bosch Rexroth products represent state-of-the-art developments and
manufacturing. They are tested prior to delivery to ensure operating safety
and reliability.

The products may only be used in the manner that is defined as
appropriate. If they are used in an inappropriate manner, then situations
can develop that may lead to property damage or injury to personnel.

Note: Bosch Rexroth, as manufacturer, is not liable for any damages
resulting from inappropriate use. In such cases, the guarantee
and the right to payment of damages resulting from
inappropriate use are forfeited. The user alone carries all
responsibility of the risks.

Before using Rexroth products, make sure that all the pre-requisites for
appropriate use of the products are satisfied:

• Personnel that in any way, shape or form uses our products must first
read and understand the relevant safety instructions and be familiar
with appropriate use.

• If the product takes the form of hardware, then they must remain in
their original state, in other words, no structural changes are permitted.
It is not permitted to decompile software products or alter source
codes.

• Do not mount damaged or faulty products or use them in operation.

• Make sure that the products have been installed in the manner
described in the relevant documentation.
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Areas of Use and Application
SyConDN is a global fieldbus configurator, that can be used in
combination with the programming software WinPCL in the system 200.
SyConDN is designed for use in the following application cases:

• Commissioning of DN devices

• Diagnostic

 Note: The fieldbus configurator SyConDN may only be used with the
accessories and parts specified in this document. If a
component has not been specifically named, then it may not
be either mounted or connected. The same applies to cables
and lines.

Operation is only permitted in the specified configurations and
combinations of components using the software and firmware
as specified in the relevant function descriptions.

2.2 Inappropriate Use

Using the fieldbus configurator SyConDN outside of the above-referenced
areas of application or under operating conditions other than described in
the document and the technical data specified is defined as "inappropriate
use".

The fieldbus configurator SyConDN may not be used

• if it is subject to operating conditions that do not meet the above
specified ambient conditions,

• for applications that Bosch Rexroth has not specifically released for
the intended purpose. Please note the specifications outlined in the
general Safety Instructions!
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2.3 Delivery Stipulations for Computer Programs

The copyrights, present and future commercial proprietary rights of all
kinds, as well as all the rights of exploitation to delivered computer
programs --  in equipment or separate from it -- belong exclusively to the
Supplier.

A computer program may only be used in one single piece of equipment.
Exceptions are commissioning software, which are marked with the
designation -COPY at the end. These can be copied freely within the
context of regular product usage by the customer.

Every act exceeding the minimum use outlined in the proprietary rights
requires the consent of the Supplier. If a computer program delivered by
the Supplier is not protected by proprietary rights, then the minimum use
stated in the proprietary rights laws is declared as agreed upon.

If the Orderer transfers a computer program then he must completely
surrender the program carrier and all copies in their entirety to the
Acquiring Party, or these must be erased. A limitation of use
corresponding to these stipulations (1 through 6) must be agreed upon
with the Acquiring Party.

The Supplier will eliminate any fault in the computer program either by a
circumvention of the fault, which is agreeable to the Orderer, or by
delivering a new program.

All documents and information needed to reconstruct a fault must
accompany the notification of a fault in the computer program.

Otherwise, the general delivery stipulations outlined by Bosch Rexroth
apply.
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3 Safety Instructions for Electric Drives and Controls

3.1 Introduction

Read these instructions before the initial startup of the equipment in order
to eliminate the risk of bodily harm or material damage. Follow these
safety instructions at all times.

Do not attempt to install or start up this equipment without first reading all
documentation provided with the product. Read and understand these
safety instructions and all user documentation of the equipment prior to
working with the equipment at any time. If you do not have the user
documentation for your equipment, contact your local Bosch Rexroth
representative to send this documentation immediately to the person or
persons responsible for the safe operation of this equipment.

If the equipment is resold, rented or transferred or passed on to others,
then these safety instructions must be delivered with the equipment.

WARNING

Improper use of this equipment, failure to follow
the safety instructions in this document or
tampering with the product, including disabling
of safety devices, may result in material
damage, bodily harm, electric shock or even
death!

3.2 Explanations

The safety instructions describe the following degrees of hazard
seriousness in compliance with ANSI Z535. The degree of hazard
seriousness informs about the consequences resulting from non-
compliance with the safety instructions.

Warning symbol with signal
word

Degree of hazard seriousness according
to ANSI

DANGER

Death or severe bodily harm will occur.

WARNING

Death or severe bodily harm may occur.

CAUTION

Bodily harm or material damage may occur.

Fig. 3-1: Hazard classification (according to ANSI Z535)
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3.3 Hazards by Improper Use

DANGER

High voltage and high discharge current!
Danger to life or severe bodily harm by electric
shock!

DANGER

Dangerous movements! Danger to life, severe
bodily harm or material damage by
unintentional motor movements!

WARNING

High electrical voltage due to wrong
connections! Danger to life or bodily harm by
electric shock!

WARNING

Health hazard for persons with heart
pacemakers, metal implants and hearing aids in
proximity to electrical equipment!

CAUTION

Surface of machine housing could be extremely
hot! Danger of injury! Danger of burns!

CAUTION

Risk of injury due to improper handling! Bodily
harm caused by crushing, shearing, cutting and
mechanical shock or incorrect handling of
pressurized systems!

CAUTION

Risk of injury due to incorrect handling of
batteries!
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3.4 General Information

• The Bosch Rexroth AG is not liable for damages resulting from failure
to observe the warnings provided in this documentation.

• Read the operating, maintenance and safety instructions in your
language before starting up the machine. If you find that you cannot
completely understand the documentation for your product, please ask
your supplier to clarify.

• Proper and correct transport, storage, assembly and installation as
well as care in operation and maintenance are prerequisites for optimal
and safe operation of this equipment.

• Only persons who are trained and qualified for the use and operation
of the equipment may work on this equipment or within its proximity.

• The persons are qualified if they have sufficient knowledge of the
assembly, installation and operation of the equipment as well as an
understanding of all warnings and precautionary measures noted in these
instructions.

• Furthermore, they must be trained, instructed and qualified to
switch electrical circuits and equipment on and off in accordance with
technical safety regulations, to ground them and to mark them according
to the requirements of safe work practices. They must have adequate
safety equipment and be trained in first aid.

• Only use spare parts and accessories approved by the manufacturer.

• Follow all safety regulations and requirements for the specific
application as practiced in the country of use.

• The equipment is designed for installation in industrial machinery.

• The ambient conditions given in the product documentation must be
observed.

• Use only safety features and applications that are clearly and explicitly
approved in the Project Planning Manual.
For example, the following areas of use are not permitted: construction
cranes, elevators used for people or freight, devices and vehicles to
transport people, medical applications, refinery plants, transport of
hazardous goods, nuclear applications, applications sensitive to high
frequency, mining, food processing, control of protection equipment (also
in a machine).

• The information given in the documentation of the product with regard
to the use of the delivered components contains only examples of
applications and suggestions.
The machine and installation manufacturer must

• make sure that the delivered components are suited for his
individual application and check the information given in this
documentation with regard to the use of the components,

• make sure that his application complies with the applicable safety
regulations and standards and carry out the required measures,
modifications and complements.

• Startup of the delivered components is only permitted once it is sure
that the machine or installation in which they are installed complies with
the national regulations, safety specifications and standards of the
application.

• Technical data, connections and operational conditions are specified in
the product documentation and must be followed at all times.
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• Operation is only permitted if the national EMC regulations for the
application are met.
The instructions for installation in accordance with EMC requirements can
be found in the documentation "EMC in Drive and Control Systems".
The machine or installation manufacturer is responsible for compliance
with the limiting values as prescribed in the national regulations.

3.5 Protection Against Contact with Electrical Parts

Note: This section refers to equipment and drive components with
voltages above 50 Volts.

Touching live parts with voltages of 50 Volts and more with bare hands or
conductive tools or touching ungrounded housings can be dangerous and
cause electric shock. In order to operate electrical equipment, certain
parts must unavoidably have dangerous voltages applied to them.

 
DANGER

High electrical voltage! Danger to life, severe
bodily harm by electric shock!
⇒ Only those trained and qualified to work with or on

electrical equipment are permitted to operate, maintain
or repair this equipment.

⇒ Follow general construction and safety regulations when
working on high voltage installations.

⇒ Before switching on power the ground wire must be
permanently connected to all electrical units according
to the connection diagram.

⇒ Do not operate electrical equipment at any time, even
for brief measurements or tests, if the ground wire is not
permanently connected to the points of the components
provided for this purpose.

⇒ Before working with electrical parts with voltage higher
than 50 V, the equipment must be disconnected from
the mains voltage or power supply. Make sure the
equipment cannot be switched on again unintended.

⇒ The following should be observed with electrical drive
and filter components:

⇒ Wait five (5) minutes after switching off power to allow
capacitors to discharge before beginning to work.
Measure the voltage on the capacitors before beginning
to work to make sure that the equipment is safe to
touch.

⇒ Never touch the electrical connection points of a
component while power is turned on.

⇒ Install the covers and guards provided with the
equipment properly before switching the equipment on.
Prevent contact with live parts at any time.

⇒ A residual-current-operated protective device (RCD)
must not be used on electric drives! Indirect contact
must be prevented by other means, for example, by an
overcurrent protective device.

⇒ Electrical components with exposed live parts and
uncovered high voltage terminals must be installed in a
protective housing, for example, in a control cabinet.
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To be observed with electrical drive and filter components:

DANGER

High electrical voltage on the housing!
High leakage current! Danger to life, danger of
injury by electric shock!
⇒ Connect the electrical equipment, the housings of all

electrical units and motors permanently with the safety
conductor at the ground points before power is
switched on. Look at the connection diagram. This is
even necessary for brief tests.

⇒ Connect the safety conductor of the electrical
equipment always permanently and firmly to the
supply mains. Leakage current exceeds 3.5 mA in
normal operation.

⇒ Use a copper conductor with at least 10 mm² cross
section over its entire course for this safety conductor
connection!

⇒ Prior to startups, even for brief tests, always connect
the protective conductor or connect with ground wire.
Otherwise, high voltages can occur on the housing
that lead to electric shock.

3.6 Protection Against Electric Shock by Protective Low
Voltage (PELV)

All connections and terminals with voltages between 0 and 50 Volts on
Rexroth products are protective low voltages designed in accordance with
international standards on electrical safety.

WARNING

High electrical voltage due to wrong
connections! Danger to life, bodily harm by
electric shock!
⇒ Only connect equipment, electrical components and

cables of the protective low voltage type (PELV =
Protective Extra Low Voltage) to all terminals and
clamps with voltages of 0 to 50 Volts.

⇒ Only electrical circuits may be connected which are
safely isolated against high voltage circuits. Safe
isolation is achieved, for example, with an isolating
transformer, an opto-electronic coupler or when
battery-operated.  

3.7 Protection Against Dangerous Movements

Dangerous movements can be caused by faulty control of the connected
motors. Some common examples are:

• improper or wrong wiring of cable connections

• incorrect operation of the equipment components

• wrong input of parameters before operation

• malfunction of sensors, encoders and monitoring devices
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• defective components

• software or firmware errors

Dangerous movements can occur immediately after equipment is
switched on or even after an unspecified time of trouble-free operation.

The monitoring in the drive components will normally be sufficient to avoid
faulty operation in the connected drives. Regarding personal safety,
especially the danger of bodily injury and material damage, this alone
cannot be relied upon to ensure complete safety. Until the integrated
monitoring functions become effective, it must be assumed in any case
that faulty drive movements will occur. The extent of faulty drive
movements depends upon the type of control and the state of operation.

 
DANGER

Dangerous movements! Danger to life, risk of
injury, severe bodily harm or material damage!
⇒ Ensure personal safety by means of qualified and

tested higher-level monitoring devices or measures
integrated in the installation. Unintended machine
motion is possible if monitoring devices are disabled,
bypassed or not activated.

⇒ Pay attention to unintended machine motion or other
malfunction in any mode of operation.

⇒ Keep free and clear of the machine’s range of motion
and moving parts. Possible measures to prevent
people from accidentally entering the machine’s range
of motion:

- use safety fences

- use safety guards

- use protective coverings

- install light curtains or light barriers

⇒ Fences and coverings must be strong enough to
resist maximum possible momentum, especially if
there is a possibility of loose parts flying off.

⇒ Mount the emergency stop switch in the immediate
reach of the operator. Verify that the emergency stop
works before startup. Don’t operate the machine if the
emergency stop is not working.

⇒ Isolate the drive power connection by means of an
emergency stop circuit or use a starting lockout to
prevent unintentional start.

⇒ Make sure that the drives are brought to a safe
standstill before accessing or entering the danger
zone. Safe standstill can be achieved by switching off
the power supply contactor or by safe mechanical
locking of moving parts.

⇒ Secure vertical axes against falling or dropping after
switching off the motor power by, for example:

- mechanically securing the vertical axes

- adding an external braking/ arrester/ clamping
mechanism

- ensuring sufficient equilibration of the vertical axes

The standard equipment motor brake or an external
brake controlled directly by the drive controller are
not sufficient to guarantee personal safety!
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⇒ Disconnect electrical power to the equipment using a
master switch and secure the switch against
reconnection for:

- maintenance and repair work

- cleaning of equipment

- long periods of discontinued equipment use

⇒ Prevent the operation of high-frequency, remote
control and radio equipment near electronics circuits
and supply leads. If the use of such equipment cannot
be avoided, verify the system and the installation for
possible malfunctions in all possible positions of
normal use before initial startup. If necessary, perform
a special electromagnetic compatibility (EMC) test on
the installation.

3.8 Protection Against Magnetic and Electromagnetic Fields
During Operation and Mounting

Magnetic and electromagnetic fields generated near current-carrying
conductors and permanent magnets in motors represent a serious health
hazard to persons with heart pacemakers, metal implants and hearing
aids.

WARNING

Health hazard for persons with heart
pacemakers, metal implants and hearing aids in
proximity to electrical equipment!
⇒ Persons with heart pacemakers, hearing aids and

metal implants are not permitted to enter the following
areas:

- Areas in which electrical equipment and parts are
mounted, being operated or started up.

- Areas in which parts of motors with permanent
magnets are being stored, operated, repaired or
mounted.

⇒ If it is necessary for a person with a heart pacemaker
to enter such an area, then a doctor must be
consulted prior to doing so. Heart pacemakers that
are already implanted or will be implanted in the
future, have a considerable variation in their electrical
noise immunity. Therefore there are no rules with
general validity.

⇒ Persons with hearing aids, metal implants or metal
pieces must consult a doctor before they enter the
areas described above. Otherwise, health hazards will
occur.
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3.9 Protection Against Contact with Hot Parts

CAUTION

Housing surfaces could be extremely hot!
Danger of injury! Danger of burns!
⇒ Do not touch housing surfaces near sources of heat!

Danger of burns!
⇒ After switching the equipment off, wait at least ten (10)

minutes to allow it to cool down before touching it.
⇒ Do not touch hot parts of the equipment, such as

housings with integrated heat sinks and resistors.
Danger of burns!

3.10 Protection During Handling and Mounting

Under certain conditions, incorrect handling and mounting of parts and
components may cause injuries.

CAUTION

Risk of injury by incorrect handling! Bodily
harm caused by crushing, shearing, cutting and
mechanical shock!
⇒ Observe general installation and safety instructions

with regard to handling and mounting.
⇒ Use appropriate mounting and transport equipment.
⇒ Take precautions to avoid pinching and crushing.
⇒ Use only appropriate tools. If specified by the product

documentation, special tools must be used.
⇒ Use lifting devices and tools correctly and safely.
⇒ For safe protection wear appropriate protective

clothing, e.g. safety glasses, safety shoes and safety
gloves.

⇒ Never stand under suspended loads.
⇒ Clean up liquids from the floor immediately to prevent

slipping.
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3.11 Battery Safety

Batteries contain reactive chemicals in a solid housing. Inappropriate
handling may result in injuries or material damage.

CAUTION

Risk of injury by incorrect handling!
⇒ Do not attempt to reactivate discharged batteries by

heating or other methods (danger of explosion and
cauterization).

⇒ Never charge non-chargeable batteries (danger of
leakage and explosion).

⇒ Never throw batteries into a fire.
⇒ Do not dismantle batteries.
⇒ Do not damage electrical components installed in the

equipment.

Note: Be aware of environmental protection and disposal! The
batteries contained in the product should be considered as
hazardous material for land, air and sea transport in the sense
of the legal requirements (danger of explosion). Dispose
batteries separately from other waste. Observe the legal
requirements in the country of installation.

3.12 Protection Against Pressurized Systems

Certain motors and drive controllers, corresponding to the information in
the respective Project Planning Manual, must be provided with
pressurized media, such as compressed air, hydraulic oil, cooling fluid
and cooling lubricant supplied by external systems. Incorrect handling of
the supply and connections of pressurized systems can lead to injuries or
accidents. In these cases, improper handling of external supply systems,
supply lines or connections can cause injuries or material damage.

 CAUTION

Danger of injury by incorrect handling of
pressurized systems !
⇒ Do not attempt to disassemble, to open or to cut a

pressurized system (danger of explosion).
⇒ Observe the operation instructions of the respective

manufacturer.
⇒ Before disassembling pressurized systems, release

pressure and drain off the fluid or gas.
⇒ Use suitable protective clothing (for example safety

glasses, safety shoes and safety gloves)
⇒ Remove any fluid that has leaked out onto the floor

immediately.

Note: Environmental protection and disposal! The media used in the
operation of the pressurized system equipment may not be
environmentally compatible. Media that are damaging the
environment must be disposed separately from normal waste.
Observe the legal requirements in the country of installation.
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Notes
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4 Installation and Licensing

4.1 System Requirements

• PC with 486-, Pentium processor or higher

• Windows 95, Windows 98, Windows NT 4.0

• Free disk space: 30-80 mbytes

• CD ROM drive

• RAM: min. 16 mbytes

• Graphic solution: min. 640 x 480 pixels

• Windows 95: Service Pack 1

• Windows NT: Service Pack 3

• Keyboard and mouse

4.2 Software Installation

Close all application programs on the system.

Insert the CD in the local CD ROM drive. The installation program will
start by itself (Autostart enabled). Otherwise change into the root directory
on the CD and start Autorun.exe (Autostart disabled).

Note: Administrator privileges are required on Windows NT systems
for installation!

The installation program asks for the components you want to install.
Answer these questions with Yes or No.

It will install

• system configurator SyConDN (configuration and diagnostic tool) and

• CIF Device Driver (Device Driver for access to the CIF).
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4.3 Installation of the System Configurator SyConDN

Follow the instructions of the installation program by selecting the fieldbus
system to be installed and answer all questions with OK or NEXT.

The installation program offers the following selections:

Selection Default settings Meaning

Directory C:\Programs\Hilscher\SyCon Installation directory of SyConDN and its components

DeviceNet Selected

INTERBUS Selected

PROFIBUS Selected

Program DLL and components of the corresponding
fieldbus system or protocol

CIF Device Driver Selected
C:\Programme\CIF Device Driver

CIF Device Driver

Program Menu SyConDN system configurator Folder under Start > Programs

Fig. 4-1: Selection during installation

The installation program copies the program files, i.e. GSD or EDS files,
and bitmaps to the PC. Finally,

• system DLLs,

• the application,

• OLE controls

are entered into the registry.
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5 Configuration Sequence

5.1 Hardware Configuration

Before you can start-up the DNM_PC104 or DNS_PC104, you must
check if the configured memory areas and interrupts are not assigned to
other devices. When using WindowsNT check this under
"Programs/Management/WindowsNT-Diagnostics/Resources“ to
recognize and eliminate errors of this kind.

Select from the following table the communication type that you want to
use. The configuration steps are described in the given chapter.

Communication Device Device Described in chapter Page

Hilscher
DeviceNet
Master

Any
DeviceNet
Device (Slave)

Configuration Hilscher DeviceNet Master to any
DeviceNet Device

5-2DeviceNet

Hilscher
DeviceNet
Master

Hilscher
DeviceNet
Slave

Configuration Hilscher DeviceNet Master to
Hilscher DeviceNet Slave

5-3

Fig. 5-1: Overview – Communication
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5.2 Configuration Hilscher DeviceNet Master to any
DeviceNet Device (Slave)

The following table describes the steps to configure a Hilscher DeviceNet
master to any DeviceNet device (slave) as it is common for many
application cases.

# Action Menu in the system configurator Detail information in
chapter

Page

1 Create a new project File > New > DeviceNet Setting up the DeviceNet
Configuration

6-1

2 Copy EDS file of the device
(slave), if the device is not in
the selection list

File > Copy EDS EDS Files 6-1

3 Select Hilscher DeviceNet
master and provide MAC ID
address

Insert > Master Insert 6-3

4 Select DeviceNet device
(slave) and provide MAC ID
address

Insert > Device Insert Device (slave) 6-7

5 Assign the input and output
modules

Mark the device (left mouse click), then

Settings > Device Configuration

Device Configuration  6-8

6 Assign the offset addresses

7 Assign the parameter data of
the device, if the device
needs parameter data

Mark the device (left mouse click), then

Settings > Device Configuration >
Parameter Data

Parameter Data 6-12

8 Set the bus parameter Mark the master (left mouse click), then

Settings > Bus parameter

Bus Parameter 7-4

9 Set the device assignment, if
no automatic assignment has
occurred

Mark the master (left mouse click), then

Settings > Device Assignment

Device Assignment 7-1

10 Save project File > Save Save and Save As 9-1

11 Download Mark the master (left mouse click), then

Online > Download

Downloading the
Configuration

8-1

12 Live list Mark the master (left mouse click), then

Online > Live List

Diagnostic Functions

Live List

8-4

13 Start debugger Mark the master (left mouse click), then

Online > Start Debug Mode

Debug Mode 8-5

14 Device diagnostic Mark the slave (left mouse click), then

Online > Device Diagnostic

Device Diagnostic 8-6

15 Stop debugger Online > Stop Debug Mode Debug Mode 8-5

16 Global diagnostic Mark the master (left mouse click), then

Online > Global Status Field

Global Status Field 8-7

17 Transfer user data:
Write outputs, read inputs

Mark the master (left mouse click), then

Online > I/O Monitor

I/O Monitor

Or: I/O Watch

8-24

8-25

Fig. 5-2: Steps for configuration of the Hilscher DeviceNet master to any
DeviceNet device (slave)
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5.3 Configuration Hilscher DeviceNet Master to Hilscher
DeviceNet Slave

The following table describes the steps to configure a Hilscher DeviceNet
master to a Hilscher DeviceNet slave as it is typical for many application
cases.

# Action Menu in the system configurator Detail information in
chapter

Page

1 Create a new project File > New > DeviceNet Setting up the DeviceNet
Configuration

6-1

2 Select Hilscher DeviceNet
master and provide MAC ID-
address

Insert > Master Insert 6-3

3 Select Hilscher DeviceNet
device (Slave) and provide
MAC ID address

Insert > Device Insert Device (Slave) 6-7

4 Assign input and output
modules

Mark the device (left mouse click), then

Settings > Device Configuration

Device Configuration 6-8

5 Assign the offset addresses
(*1)

6 Assign the bus parameter Mark the master (left mouse click), then

Settings > Bus Parameter

Bus Parameter 7-4

7 Set device assignment for the
master, if no automatic
assignment has occurred
(master)

Mark the master (left mouse click), then

Settings > Device Assignment

Device Assignment 7-1

8 Set device assignment, if no
automatic assignment has
occurred (slave)

Mark the device (left mouse click), then

Settings > Device Assignment

Device Assignment 7-1

9 Save project File > Save Save and Save As 9-1

10 Download (master) Mark the master (left mouse click), then

Online > Download

Downloading the
Configuration

8-1

11 Download (slave) Mark the device (left mouse click), then

Online > Download

Downloading the
Configuration

8-1

12 Live list Mark the master (left mouse click), then

Online > Live List

Diagnostic Function

Live List

8-4

13 Start debugger Mark the master (left mouse click), then

Online > Start Debug Mode

Debug Mode 8-5

14 Device diagnostic Mark the slave (left mouse click), then

Online > Device Diagnostic

Device Diagnostic 8-6

15 Stop debugger Online > Stop Debug Mode Debug Mode 8-5

16 Global diagnostic Mark the master (left mouse click), then

Online > Global Status Field

Global Status Field 8-7

17 Transfer user data:

Write outputs, read inputs

Mark the master (left mouse click), then

Online > I/O Monitor

I/O Monitor

Or: I/O Watch

8-24

8-25

Fig. 5-3: Steps for the configuration of the Hilscher DeviceNet master to
Hilscher DeviceNet slave
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Remark (*1): The offset addresses assigned in the slave configuration are
always related to the Hilscher DeviceNet master and have no meaning
here.

Remark (*2): Alternatively, the CIF Device Driver Test Program can be
used for the test. After Board Select: Data Transfer > I/O Data >
DevExchangeIO.
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6 DeviceNet Configuration with SyConDN

6.1 Setting up the DeviceNet Configuration

To create a new configuration, select the File > New menu. This will offer
a selection list of fieldbus systems. Choose DeviceNet. If only the
fieldbus DeviceNet was installed, the configuration window will open
directly.

The name of the configuration file can be allocated when the configuration
is terminated or with File > Save As.

6.2 EDS Files (Electronic Data Sheet Files)

Introduction
An Electronic Data Sheet (EDS) provides information necessary to
access and change the configurable parameters of a device. An EDS is
an external file that contains information about configurable attributes for
the device, including object addresses of each parameter.

The application objects in a device represent the destination addresses
for the configuration data. These addresses are encoded in the EDS.

The figure below shows a general block diagram of an EDS file.

Device Parameter 1

Device Parameter X

EDS

Standard Device Profile

Standard Device Profile

Device Parameter 1

General Device
Information

Vendor-Specific

Device Parameter X
Vendor-Specific

Optional

Fig. 6-1: General block diagram of an EDS file
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EDS Files and SyConDN
When the system configurator is started, it automatically retrieves all EDS
files stored in the EDS directory. The device names are placed into an
internal list. During the configuration, the device-specific data is retrieved
directly from the EDS files.

If a DeviceNet device does not appear in the selection list (Insert Master
or Insert Device), then the corresponding EDS file can be copied into the
EDS directory with File > Copy EDS. Another possibility is to copy the
EDS file into the SyConDN EDS directory with Windows Explorer and
then retrieve the EDS files into the EDS directory with Settings > Path
and OK.

• Hilscher devices: The EDS files for Hilscher devices are already
included in the scope of delivery of the system
configurator and are installed with the system
configurator.

• Other devices: For other devices the respective device
manufacturer provides the EDS files.

The EDS files of some vendors are available on the Open DeviceNet
Vendor Association (ODVA) homepage:

http://www.odva.org

or visit the homepage of the manufacturer.

The EDS directory is adjustable. In order to change the directory from a
previous setting in another directory, use the menu Settings > Path. All
EDS files must be placed in this directory.
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6.3 Master

Insert Master
To insert a (Hilscher) master into the configuration, select the Insert >
Master menu, in order to open the selection window, or click on the
symbol:

The mouse pointer automatically changes into the Insert Master pointer.
Click on the position where the master is to be inserted. The dialog box,
from which one or more masters can be chosen, opens.

Dn4_1.bmp

Fig. 6-2: Insert > Master

The MAC ID of the master can be changed here.

The Description field will accept up to 32 characters of text. This text will
appear later in the main configuration window.

The chosen master is automatically placed at the first position in the main
configuration window, if the selection was confirmed with the OK button.

If a master is already placed, SyConDN will ask for a replacement
confirmation. Already inserted devices are not influenced by this
procedure and remain configured.

Dn4_2.bmp

Fig. 6-3: Question in case of master replacement
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Automatic Network Scan
After the master device is configured, it is possible to scan the DeviceNet
network for other devices (automatic network scan), whereby other
devices are automatically searched. This allows a very fast configuration,
and you also have the possibility to change detailed parameters for these
devices later.

To start an automatic network scan, please proceed as follows:

1. Insert a master device.

2. Click on Settings > Bus parameters and select the baudrate and the
MAC ID from the master (explained in chapter Bus Parameter on
page 7-3).

3. Select Online > Download to load these settings into the DeviceNet
master.

4. Click on the master with the left mouse button and choose Online >
Automatic Network Scan.

5. A new window is displayed, where you see the current status of the
network scan and the devices, which were already found in your
DeviceNet network:

Dn4_3.bmp

Fig. 6-4: Online > Automatic network scan (during scanning)

The network scan will take approx. 30 seconds. The network scan is still
in progress and could not be interrupted until the status, shown in the field
"Current Status", changes to "Ready!". When the scan is done, you see
the devices that were found at the corresponding MAC ID address in the
table.
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Example:

Dn4_4.bmp

Fig. 6-5: Online > Automatic network scan (after scanning)

In our example in the figure above the automatic network scan detected a
Hilscher device at MAC ID 1.

Here is an explanation of the different columns:

Variables Meaning

Supported functions Functions supported by the device, could be polled, bit strobe or cyclic/change of state
(explained in chapter Actual selected I/O Connection starting on page 6-9)

Device name Name of the device, result from network scan

Poll size produced Number of data for poll connection (inputs)

Poll size consumed Number of data for poll connection (outputs)

BitStr. size produced Number of data for bit strobe connection (inputs)

BitStr. size consumed Number of data for bit strobe connection (outputs)

Cyc/COS size produced Number of data for cyclic/COS connection (inputs)

Cyc/COS size consumed Number of data for cyclic/COS connection (outputs)

Selected config. Configuration chosen by the user, could be Change of State, Cyclic, Polling, Bit strobed
or explicit only and depends on the functions supported by the device. Click on the cell
to change the configuration.

Fig. 6-6: Explanations to Fig. 6-5 "Online > Automatic network scan (after
scanning)"
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A double-click on the first or second column of the corresponding row of
the device shows detailed information of the device:

Dn4_5.bmp

Fig. 6-7: Information on a device in the automatic scan window

If you want to use this configuration as your configuration, click on
Automatic Configuration and select Yes when prompted. Afterwards
you can close the Automatic Configuration Window by clicking on OK. If
you do not want the devices that were found in your configuration, just
click OK.

If you want to insert your devices manually, please go on with section
"Insert Device (Slave)" starting on page 6-7.
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6.4 Device (Slave)

Insert Device (Slave)
To insert new DeviceNet devices in the configuration select the Insert >
Device menu to open the selection window or click onto the following
icon:

Insert > Device Insert Device Mouse Pointer

The mouse cursor changes automatically to the insert device pointer.
Click on the position where you want to insert the new device. A dialogue
box appears where you can select now one or more devices for insertion.

Dn4_6.bmp

Fig. 6-8: Insert > Device (Slave)

The left list box is listing all available devices, whose EDS files are
present in the EDS directory. You can use a filter to reduce the selection
possibilities via Type and Vendor. lf one device is selected, you can see
some additional information about that device below the list box
(Available devices). With a double click or with the button Add, the
device appears in the right list box. All devices in the right list are
assigned to the current Master, which is also displayed in this window. If
you select bit by bit every device in the right list (one mouse click), you
can assign one Mac ID as well as a name to each slave in the input box
Description. The description field will accept up to 32 characters of text.

For each device registered in the right list the MAC ID is automatically
increased one digit. However, it can be overwritten by the user in the input
box.
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Note: It is allowed to select one device several times. However, each
device needs its own (unique) MAC ID, so that it can be
recognized in the network.

Device Configuration
To enter the Device Configuration set the focus on the device (left
mouse click) and select the menu Settings > Device Configuration or
set the focus on the device (left mouse click) and use the right mouse
button at the device or simply double-click on the device.

This window is used to execute the device-specific configuration. In the
device configuration you have to assign the device’s I/O to logical
addresses in the process data image of the master. Please consider that
these addresses have to correspond to the addresses of the PC
application.

Dn4_7.bmp

Fig. 6-9: Device configuration

Note 1: The offset addresses set in this window are for the addressing
of the input data and output data in the master! These address
settings (offsets) are not the settings in the DeviceNet device
(slave). The DeviceNet device (slave) organizes its data itself.

Note 2: The input data and the output data from the bus are
transferred directly  to the Dual-Port Memory in the Hilscher
DeviceNet slave. These offset addresses are related to the
master.
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The EDS file which this device is using is displayed next to File Name.

The Description and MAC ID fields displays the entries made during the
selection phase of the slave device. Both entries can be set/changed
here.

The checkbox Activate Device in actual configuration decides, if the
master tries to establish the communication to the device or not. Disabling
this button makes sense for example, if a device is physically not present
in the network, but will be present in future. This suppresses unnecessary
requests of the master to non existing devices, but the device insertion
itself reserves process data in the process data image of the master.

MAC ID (Device Network Address)
The network address of a device serves to distinguish itself on a
DeviceNet fieldbus system from any other device or slave on this network.
This should be a unique number for each device. A valid MAC-ID address
is within a range of 0 to 63 and can be reentered and changed in the
MAC-ID box in the Device Configuration dialog.

Actual selected I/O Connection
DeviceNet allows to establish several kinds of I/O connections between
devices. Please note that a device has not to support all types of IO
connections.

I/O connection

Poll

Bit Strobe

Change of State

Cyclic

Fig. 6-10: Overview I/O connections
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Here is an explanation of the different connections types.

• Polled I/O Connection - One poll command from the master sends a
number of output data to a single, specific device (point-to-point). The
device receives (consumes) the poll command and processes the
output data. If it has input data configured for this poll connection, it
reacts by sending (producing) back a number of input data and/or
status information to the master. Before a polled I/O connection is
initiated by the master, it reads the Consumed and Produced
Connection Size of the data from the slave first and compares each
value with the internally configured one. If the master detects
differences, the connection cannot be established. Sending a poll
command can happen at any time the master wants to and has timer
or event dependencies. A device has to respond, if it has consumed
and understood the poll command request of the master, even if it has
no input data. Else the master will report a timeout error. Polling data
to many devices has the disadvantage that the network traffic rate is
very high and most data which is transferred has not changed since
the last transmission. Furthermore, the higher the bus load the more
communication errors can occur, if the bus is disturbed by external
influences.

• Bit Strobe I/O Connection - Bit strobe command and response
messages rapidly move small amounts of I/O data between the master
device and one/some/all slave devices. The bit strobe message
contains a bit string of 64 bits of output data, one output bit per
possible device. Each bit in there is assigned to one device address in
the network. Herewith, this service has broadcast functionality that
means more than one slave device can be addressed by one
command. Because all addressed slave devices get this command at
the same time, this command is normally used to synchronize data
transfer to several slave devices. A slave device can take its
corresponding output bit as a real output information to give it to the
peripheral connections (e.g. an LED) and/or use the bit as a trigger to
send back its input data with a poll response message. The data that
can be send back from each slave after a bit strobe command was
received is limited to 8 bytes in length. Bit strobe usage causes
therefore a reduced bus loading than poll connections.

• Change of State/Cyclic I/O Connection - The master device sends a
number of output data to a single, specific device (point-to-point). Data
production is triggered by either a determined changed value in the
output data or the cyclic timer expiration. Depending on how the slave
behavior is configured, the slave can send back an acknowledge
message, containing a number of input data and/or status information.
The slave device sends a number of input data to the master, if the
data is either changed or the cyclic timer has expired. The master itself
can acknowledge this message with output data if configured.

A data production only with "Change of state/Cyclic" holds down the
bus load as small as possible, while data than can be transmitted as
fast as possible by each device, because bus conflicts are less
possible. So you can get high performance data transmission with in
comparison low baud rates.
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Connection Object Instance Attributes
The Production Inhibit Time, one for each connection, configures the
minimum delay time between new data production in multiples of a
millisecond. The timer is reloaded each time new data production through
the established connection occurs. While the timer is running, the device
suppresses new data production until the timer has expired. This method
prevents that the device is overloaded with to fast incoming requests.

The value 0 defines no inhibit time and data production can and will be
done as fast as possible. If, for example, in polled mode a Production
Inhibit Time of 1000dec is configured, then the poll request message to
the device will be sent every second.

The Expected Packet Rate, one for each connection, is always
transferred to the device before starting and doing the I/O transfer. The
value is used by the device later to reload its ’Transmission Trigger’ and
’Watchdog Timer’. The ’Transmission Trigger Timer’ is used in a ’cyclic’
I/O connection to control the time, when the data shall be produced.
Expiration of this timer then is an indication that the associated
connection must transmit the corresponding I/O message. In ’change of
state’ connections the timer is used to avoid the watchdog timeout in this
connection, when a production has not occurred since the timer was
activated or reloaded.

Note: The Production Inhibit Time is verified against the Expected
Packet Rate. If the Expected Packet Rate value is unequal
zero, but less than the Production Inhibit Time value, then an
error window is opened, when pressing the OK button or
changing to a wrong value.

The Watchdog Timeout Action defines the device behavior, when the
watchdog timer in the device expires. The following values are defined
and their functionality is closer described in the DeviceNet specification.

• Transition to Timed Out: The connection transitions to a Timed Out
state and remains in this state until it is Reset or Deleted.

• Auto Delete: The connection class automatically deletes the
connection, if it experiences an Inactivity/Watchdog timeout.

• Auto Reset: The connection remains in the established state and
immediately restarts the Inactivity/Watchdog timer.

UCMM Check
The UCMM Check box is used for modules that require the use of UCMM
messaging format. Class 1, 2, and 3 are supported. Check the
documentation for your slave device to identify, if this box must be
checked.

Fragmented Timeout (Expl. Message Timeout)
If a transmission of I/O data or explicit message is greater than 8 bytes in
length, it must be transmitted on DeviceNet in a fragmented manner. The
maximum time the master will wait until a slave has to respond during the
fragmented transmissions is the fragmented timeout.
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Parameter Data
The button Parameter Data can be selected in the Device Configuration
window to edit the parameter data.

If default parameters are configured in the EDS file for this device, they
are inserted automatically, when the menu is chosen the first time.

Some of the devices need some further parameterization data to change
for example a measurement limitation or a value range. These data is
device-specific and their functionality can not be explained at this point.

This window below shows an example of parameter data of a device.

Dn4_8.bmp

Fig. 6-11: Parameter data

Two tables are available: one table with all available parameters and one
table for customized parameters. These parameters can be selected from
the available parameters to that table.
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Process Data Configuration
• Fixed I/O data transfer

DeviceNet handles I/O data transparently as a byte string without
defining any data type in the transferred data. To be operative it
defines only the number of bytes in consumed and produced direction
that shall be transferred across a connection, nothing else. But
SyConDN and the firmware now allows to assign modular each byte or
a bunch of bytes of the transparent string to different data types. A list
of the supported data types of the connection can be found in the
middle table of the window (see Fig. 6-11) called Available
Predefined Connection Data Types. These available predefined
data types are registered in the EDS file of the respective device. If
there are no data types available, SyCon specifies data types: Byte
Array Input Data and Byte Array Output Data.

The following data types are supported:

• Bit, Byte, Word, Dword, Byte Array

By selecting one of the available predefined connection data types and
by clicking on Add or double-clicking on the predefined connection
data type this data type is entered in the lower table containing the
Configured I/O connection data types and their offset addresses.

If the data type Byte Array is chosen, the number of bytes that shall
be reserved for this data type can be entered in the Data Count
column in the lower table. Any other data type has its fixed length that
can not be changed. The data types are distinguished in process
output and process input data in the view of the master device.

A double-click on a predefined data type or a click in the Add to
configured I/O data button will insert the chosen data type in the
lower table called Configured I/O connection data. This table
contains all data that shall be really transferred across the connection.
SyConDN will add separately the number of used bytes of each
configured I/O data and forms the values Consumed and Produced
Connection Size automatically. Both values indicates the sum of
bytes which shall be sent by the master as outputs (Consumed by the
device) and received by the master as inputs (Produced by the
device).

• Assigning the process data offset addresses

The I/O offset addresses of each placed data type in the connection
data table can be freely configured in a range of 0 to 3583 or they are
set automatically by SyConDN. To enable or disable free configuration
use the flag Auto Addressing in the menu Settings - Auto
Addressing. If enabled SyConDN will place all configured I/O data
spaceless in physical order one to each other based on the rising
MAC-ID order. This is done during the download procedure. The
assigned addresses can be checked then in the overview Address
Table of the menu View. If the addresses are entered manually the
default address 0 in the input address respectively the output
address must be overwritten. Depending on the Addressing mode in
the DNM Master Settings the addresses are byte addresses or word
addresses. This is described in the chapter.
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In case of manual addressing (that means auto addressing is
deactivated) the configuration window looks like:

Dn4_9.bmp

Fig. 6-12: Device configuration for manual addressing

In the column I Addr and O Addr you have to assign the addresses,
where to locate the data in the process image. Remember that these
addresses correspond to your application on the HOST side.

If you deactivate a device in the actual configuration the device is shown
like this:

Dn4_10.bmp

Fig. 6-13: Display when device is deactivated

To activate or deactivate a device in a configuration can be very useful for
such devices which don’t exist in the real physical network, but for which
the I/O offset addresses shall be reserved or simply a symbolic ’missing
device’ wanted to be inserted as long as the device is not connected.
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7 Settings

7.1 Device Assignment

The device assignment setting determines, how the system configurator
communicates with the device. This is set in the device arrangement via
the menu Settings > Device Assignment. The following possibilities are
available:

CIF Device Driver CIF Serial Driver

CIF Device Driver:

• CIF Device Driver: The system configurator communicates with the
Hilscher device over the Dual-Port Memory of the device.

• This communication is utilized, when the system configurator is used
on the same PC on which the Hilscher device (CIF) is installed.

• The CIF Device Driver must have been installed.

CIF Serial Driver:

• CIF Serial Driver: The system configurator communicates with the
Hilscher device via a serial connection. Thereby, a COM interface of
the PC must be connected via a diagnostic cable with the diagnostic
interface of the Hilscher device.

• This communication is utilized when the system configurator is to
access the device over the diagnostic interface of the Hilscher device.
The following two application cases are possible:

• Application case 1: The system configurator is installed on another PC
(e.g. a notebook) than the Hilscher device.

• Application case 2: The system configurator is installed on the same
PC, on which the Hilscher device is situated. Then the application can
use the Dual-Port Memory to access the Hilscher device and the
diagnostic interface can be used at the same time to communicate
with the device (diagnostic data).
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CIF Serial Driver
The serial driver supports COM1 to COM4, in order to communicate over
the diagnostic interface with the device.

The Device is selected via Settings > Device Assignment.

Dn5_4.bmp

Fig. 7-1: Driver selection – CIF Serial Driver

Choose the item CIF Serial Driver and then OK, in order to select the
CIF Serial Driver.

The connection must first be established using the switching surface
Connect COM1 or Connect COM2 or Connect COM3 or Connect
COM4. They can be used depending on which COM interfaces are
installed and free on the PC.

The system configurator sends a request to the corresponding COM
interface and polls the firmware of the device. A display of the firmware
will indicate, when a device is connected. In the other case, a Timeout
error (-51) appears, which will state that no device is connected.

Dn5_5.bmp

Fig. 7-2: CIF Serial Driver – Device assignment
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The error number –20 indicates that this COM interface is not available or
not free.

Dn5_6.bmp

Fig. 7-3: CIF Serial Driver – Device assignment
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7.2 Bus Parameter

In this window the basic settings for the DeviceNet network must be done.

Dn5_9.bmp

Fig. 7-4: Settings > Bus parameters

Mainly, this concerns the determination of the Baudrate. The DeviceNet
board supports the baudrates 125kbit/s, 250kbit/s and 500kbit/s.
Normally, DeviceNet components use the autobaud detection to get the
baudrate automatically one-time.

The Auto Clear mode feature defines the behavior of the master, if the
communication breaks down or is interrupted to a device. If the flag Auto
clear mode ON is activated, the master will also stop the communication
to all further devices which were still responding and active. If the flag
Auto clear mode is not activated, then a lost communication contact to
one device has no influence on the communication channel of the still
present ones. For all the error effected devices the master remains in the
state to try the reestablishment of the communication again.
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7.3 DeviceNet Master

DeviceNet Master Settings
To enter the DeviceNet master settings set the focus on the master (left
mouse click) and select the menu Settings > Master Settings or set the
focus on the master (left mouse click) and use the right mouse button at
the DeviceNet master device or simply double-click on the DeviceNet
master device.

The DeviceNet master settings contain parameters defining the behavior
of the device as well as of its user interface which is not a part of the
DeviceNet configuration directly. This menu is only valid for Hilscher
devices, and is downloaded with the DeviceNet configuration.

Dn5_10.bmp

Fig. 7-5: DeviceNet master settings
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• Startup behavior after system initialization

If Automatic release of the communication by the device is
selected, the master starts with the data transfer on the bus when
initialization is finished. If Controlled release of the communication
by the application program is selected, the user has to start the data
transfer on the bus, by a defined release procedure.

• User program monitoring

The watchdog time appointed defines, how long the device will wait for
a user trigger of the software watchdog if started once, until it resets all
outputs of the device to zero. This procedure must be activated by the
user application and is not started automatically.

Note: This is no special DeviceNet function.

This function is, for example, used by a soft PLC.

• Addressing mode

The addressing mode of the process data defines, how to interpret the
addresses of the process image. Possibilities are Byte addresses or
Word addresses. See details on the next page.

• Storage format (word module)

The storage format fixes the format, how the data words are placed
and interpreted in the process images. For the data type word the
Little Endian format and Big Endian format can be selected.

• Handshake of the process data

With these different modes the handshake of the process data is
selected for the master. The selection of this mode is important for the
correct data exchange between the application and the device.

• Hardware parameter

With this parameter you select the size of the Dual-Port Memory of the
hardware. The parameter will enlarge or reduce the possible value
ranges for the I/O offsets.

Auto Addressing
If this option is activated, the system configurator allocates the process
data addresses in physical order itself. If this option is deactivated, the
process data have to be manually addressed. Please, see also chapter
Process Data Configuration on page 6-13.
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Addressing Mode
The addresses in the configuration of the devices define the starting point
of the data in the process depiction. This can work in a word- or byte-
oriented method by means of the Addressing mode parameter.

Byte addresses The process depiction has a byte structure and each 
byte has its own address.

Word addresses The process depiction has a word structure and each 
word has its own address.

This has nothing to do with the physical size of the Dual-Port Memory –
this is always byte-oriented! When the application makes a word access,
it is automatically divided by the PC into two sequential byte accesses.

The following table shows the different storing of the various data types in
the byte- or word-oriented process image:

IEC address IEC address Offset address in the Data in the                 Output to an I/O module

in byte mode in word mode Dual-Port Memory process image

QB 0 QB 0 0 0000 0000

QB 1 1 0000 0000

QB 2 QB 1 2 1110 0010

Output of QB2 / QB1 to a single byte module:
D7 D6 D5 D4 D3 D2 D1 D0
  1    1    1   0   0   0   1   0

QB 3 3 0000 0000

QB 4
QB 5

QB 2 4
5

1111 1000
0000 0111

Output of two bytes beginning from QB4 / QB2 to a module that
is defined as a byte module with the data count 2
(no differentiation between the two memory formats as the data
are of byte type):
D7 D6 D5 D4 D3 D2 D1 D0  D7 D6 D5 D4 D3 D2 D1 D0
  1    1    1    1   1   0   0   0      0    0    0   0    0   1   1   1

QW 6 QW 3 6
7

1111 1111
0100 0100

Output of QW6 / QW3 in the data format lower/higher value
byte:
D15 D14 D13 D12 D11 D10 D9 D8 D7 D6 D5 D4 D3 D2 D1 D0
   0     1     0      0      0     1     0    0    0   1    1   1    1   1    1   1

Output of QW6 / QW3 in the data format higher/lower value
byte:
 D15 D14 D13 D12 D11 D10 D9 D8 D7 D6 D5 D4 D3 D2 D1 D0
    1     1     1     1      1      1     1    1    0   1    0    0    0   1    0   0

Fig. 7-6: Storing of the different data types
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The following table is meant to clarify the method of addressing:

Byte addressing Word addressing

Byte 0 IB 0 IB 0

Byte 1 IB 1

IW 0 Word 0

-

IW 0

Byte 2 IB 2 IB 1

Byte 3 IB 3

IW 1 Word 1

-

IW 1

Byte 4 IB 4 IB 2

Byte 5 IB 5

IW 4 Word 2

-

IW 2

Fig. 7-7: Image of the method of addressing for input

Byte addressing Word addressing

Byte 0 QB 0 QB 0

Byte 1 QB 1

QW 0 Word 0

-

QW 0

Byte 2 QB 2 QB 1

Byte 3 QB 3

QW 2 Word 1

-

QW 1

Byte 4 QB 4 QB 2

Byte 5 QB 5

QW 4 Word 2

-

QW 2

Fig. 7-8: Image of the method of addressing for output
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7.4 Device (Slave)

Device Configuration
A double-click on the device icon will open the Device Configuration
window. The same happens, if you set the focus on the device (left
mouse click) and enter the menu Settings > Device Configuration.
Chapter Device Configuration on page 6-8 describes this configuration.

DeviceNet Settings (Slave Settings)
The DeviceNet slave settings contain parameters defining the behavior of
the slave device on its user interface, which is not a part of the DeviceNet
configuration. This menu is only valid for Hilscher devices, which can be
directly downloaded with the DeviceNet configuration.

To enter the DeviceNet slave settings set the focus on the slave and open
the window with the menu Settings > Device Settings.

Dn5_11.bmp

Fig. 7-9: DeviceNet slave settings
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• Startup behavior after system initialization

If Automatic release of the communication by the device is
selected, the slave is ready to communicate with the master when
started. If Controlled release of the communication by the
application program is selected, the user has to release
communication by a defined release procedure.

• User program monitoring

This function is not supported by the DeviceNet slave.

Note: This is no special DeviceNet function.

This function is, for example, used by a soft PLC.

• Handshake of the process data

With this different modes the handshake of the process data is
selected for the slave. The selection of this mode is important for the
correct data exchange between the application and the device. Please
refer to the tool kit or the device driver manual for the detailed
description of these modes.

• Autobaud On

Activates or deactivates the automatic baudrate detection of the
Hilscher DeviceNet slave.

7.5 Project Information

If the user creates his own project, the project information can be written
into the Settings > Project Information menu. Anybody can then read
this entry when this menu is called up.

Dn5_12.bmp

Fig. 7-10: Settings > Project information
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7.6 Path

In the menu Settings - Path the path directory of the EDS files is shown
(EDS File directory). The default value is
C:\Programme\Hilscher\SyCon\Fieldbus\DEVNet\EDS

The path for project directory defines the path where the project specific
files are stored.

Dn5_13.bmp

Fig. 7-11: Settings > Path

7.7 Language

Choose the Settings > Language menu and the following window opens:

Dn5_14.bmp

Fig. 7-12: Settings > Language

Here one is in a position of setting the language of the system
configurator. Select the desired language and confirm the entry with the
OK button.

A message appears that the system configurator must be started again in
order to activate the selected language. Please carry this out.

After restarting the system configurator, the language will have changed
to the one selected.

Note: Up to now, not all languages are available for all fieldbuses!
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7.8 Start Options

After activating the Settings > Start Options menu point in the network
mode (you can change to the network mode by choosing Window >
Logical Network View), the dialog illustrated below will appear.

Here it is possible to set the various starting options or modes. Some are
of importance only for the OPC-Server operation.

The important ones are given below.

Dn5_15.bmp

Fig. 7-13: Settings > Start options

• Simulation mode ON/OFF

Only valid for the OPC Server.

• Start SyConDN hidden if started via OPC

Only valid for the OPC Server.

• Start SyConDN next time with last Configuration

When this item is selected the last saved configuration in the
SyConDN is automatically loaded, when the SyConDN is started
again.

• Logic Network View visible

When this is selected possibility of diverting to the network mode
without having to install the SyConDN with OPC. It is also possible to
use the Watch List from the network mode.

• Fast start ON/OFF

Only valid for the OPC Server.

• TAG tracing ON/OFF

Only valid for the OPC Server.

• OPC tracing ON/OFF

Only valid for the OPC Server.
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8 Online Functions
In this section all the functions are described that directly affect the
Hilscher DeviceNet device.

Please note that this will also permit interruption of a running
communication or that outputs can be switched On or Off.

8.1 Online to the CIF

Downloading the Configuration
First, chose the desired device for downloading with a left mouse click on
the symbol of the device.

In order to release the configuration and network access, a transfer
(Download) to the master devices must be carried out on the Online >
Download menu. A warning will appear, that the communication on the
DeviceNet will be interrupted. This warning must be confirmed.

Dn6_1.bmp

Fig. 8-1: Security prompt before downloading

Dn6_2.bmp

Fig. 8-2: Online > Download

Before the download is carried out, the configuration is tested by the
configurator. The most common error cause is overlapping of addresses
in the process data image. This can be checked by calling up the address
table with the View > Address Table menu point.

If the issue of addresses in the process data image is carried out
automatically, then the Auto addressing button in the Master
Configuration window must be activated.
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The configuration is transferred into the selected device and is stored
there in FLASH memory in a zero voltage manner, so that the
configuration is available, when the voltage supply is switched off and on
again.

After the download, the device carries out an internal restart and begins
with the communication, if in DeviceNet Master Settings the Automatic
Release of Communication by the Device menu point has been set.

Firmware Download
If a firmware download is to be carried out, proceed as follows: first,
chose the desired device for firmware downloading with a left mouse click
on the symbol of the device. Then, call up the Online > Firmware
Download menu. Select the new firmware and click then on the button
Download. The firmware is now downloaded into the device.

Dn6_3.bmp

Fig. 8-3 Online > Firmware download

Firmware / Reset
First, chose the desired device with a left mouse click on the symbol of
the device. Then, call up the Online > Firmware / Reset menu. Now,
name and version of the firmware are displayed.

Dn6_4.bmp

Fig. 8-4: Online > Firmware / Reset
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Device Info
First, chose the desired device with a left mouse click on the symbol of
the device. Then, select the Online > Device Info menu, in order to
obtain further information on the selected device.

The manufacturer date, the device number and the serial number of the
device is retrieved and shown.

Dn6_5.bmp

Fig. 8-5: Online > Device info

8.2 Start/Stop Communication

First, chose the desired device with a left mouse click on the symbol of
the device. Then, select the menu item Online > Start Communication
or Online > Stop Communication to start or stop the communication
between a DeviceNet Master and DeviceNet Slave manually.



8-4 Online Functions SyConDN

           DOK-CONTRL-SYCON****DN-AW02-EN-P

8.3 Diagnostic Functions

Live List
If you select the menu Online > Live List, you will get an overview of all
devices physically present in the actual network constellation. Present
devices are displayed in black, all other non-present devices are
displayed in grey. The live list works online. If you connect or disconnect
one station, you will see the result as soon as SyConDN collects the latest
live list from the master board. Remember that all devices on DeviceNet
have to proceed the autobaud detection phase first to get wholly run. This
can take up to some milliseconds.

Dn6_7.bmp

Fig. 8-6: Online > Live list
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Debug Mode
First, chose the desired master device with a left mouse click on the
symbol of the master. Then, click on menu item Online > Start Debug
Mode. The system configurator cyclically interrogates the status of the
network communication on the CIF, COM or PKV and the individual
condition of the devices.

To end the Debug Mode select the menu Online > Stop Debug Mode.

The Debug Window

When started the debug session the configuration window changes into
the debug window. The devices and the line between them are displayed
in green or red color depending on the established network
communication.

Dn6_8.bmp

Fig. 8-7: Debug window

If a diagnostic information is available for a specific device, the text Diag
next to the device icon appears in red. To get further device-pecific
diagnostic information, double-click on the device itself or set the focus to
the device and select Online > Device Diagnostic.
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Device Diagnostic
After starting the debugger the SyConDN requests the status of all
devices from the master. If there is an error on a device, the bus line to
this slave is displayed in red color otherwise in green color. SyConDN
also displays the letters Diag, if the device signals a diagnostic
information. You will receive further diagnostic information, if you double-
click on this device in debug mode.

To activate the debug mode, select the menu Online > Start Debug
Mode. The menu Online > Device Diagnostic activates the DeviceNet
device diagnostic. To end the Debug Mode, select the menu Online >
Stop Debug Mode.

Dn6_9.bmp

Fig. 8-8: Online > Device diagnostic

The Device Diagnostic and its meaning:

• No response

The device is configured, but is not present in the network. Please
check the physical connection between the master and this device.
Check also the chosen baudrate, and if this baudrate is supported by
this device.

• Error buffer overflow

DeviceNet defines a special reserved error channel for each slave with
high priority to allow each device to report emergency messages
triggered by the occurrence of a device internal fatal error situation.
The emergency messages of each device are collected in an internal
buffer of limited size. In this case, the buffer overflow event is reported.

• Parameterization fault

The master compares the configured Device Profile and the
corresponding Device Type value of the Device Configuration
window with the real physically present ones in the slave by retrieving
one slave configuration object from the device. If the master detects
differences between the values, it will report the parameterization fault.

• Configuration fault

A configuration fault will occur, if a difference is seen between the
configured produced/consumed data size and the actual slave
produced/consumed data size.

• UCMM support

The box will be checked, if the slave device requires UCMM support.

• Deactivated

This bit is set by the master automatically, if the device state was
configured to Deactivate Device in actual configuration in the
Device Configuration window.
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Global State Field
First, select the master device by clicking on the corresponding icon with
the left mouse button. Select the menu Online > Global State Field to
see details about the global state field. A window opens, in which status
messages about the bus state and the connected devices are displayed.

The first row shows the online master main state e.g. OPERATE, STOP.

The next row shows single bus errors. A detected error is displayed in a
red field. The meaning of the short cuts is listed below:

Dn6_10.bmp

Fig. 8-9: Online > Global state field

Collective status bits

PDUP: DUPLICATE-MAC-ID check
The device is involved in the duplicate MAC-ID check procedure, 
to check if other devices with the same address are connected to 
the network. The duplicate MAC-ID check will be finished, if at 
least one DeviceNet device could have been found connected to 
the network.

DMAC: Duplicate MAC-ID detected
The DEVICE has stopped the duplicate MAC-ID check procedure 
and found an other device having the same MAC-ID address. 
Change the DEVICE address to avoid this failure.

NRDY: HOST-NOT-READY-NOTIFICATION
indicates, if the host program has set its state to operative or not. 
If this bit is set, the host program is not ready to communicate.
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EVE: EVENT-ERROR
The used CAN chip has detected transmission errors. The
number of detected events is counted in the Bus Off Reports and
the Error Warning Limit Counter. The bit will be set, when the first
event was detected and will not be deleted any more.

FAT: FATAL-ERROR
Because of several bus errors, no further bus communication is
possible.

NEXC: NON-EXCHANGE-ERROR
At least one device has not reached the data exchange state and
no process data is exchanged with it.

ACLR: AUTO-CLEAR-ERROR
The device stopped the communication to all other devices and
has reached the auto-clear end state.

CTRL: CONTROL-ERROR
Master parameterization error detected.

Further information:

Collective online error location and corresponding error

Statistical bus information

Device specific status bits: Parameterized Devices, Activated Devices
and Devices with Diagnostic are shown, if you click on this button. The
activated addresses are displayed in another color.

If you have chosen Devices with diagnostic, some devices are
displayed in another color. If you click on the device addresses of this
devices, you can see the device diagnostic of this special device.

All information is cyclically updated.
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Extended Device Diagnostic

Master
The extended device diagnostic assists in finding bus and configuration
errors when the SyConDN menu functions are of no further help.

First, chose the desired device with a left mouse click on the symbol of
the device. Then, select the Online > Extended Device Diagnostic
menu.

This menu opens a list of diagnostic structures. These contain
parameters and counters which can be retrieved now:

Dn6_11.bmp

Fig. 8-10: Extended device diagnostic

The task states available for the Hilscher DeviceNet master are:

[PLC_TASK] Common variables

[DNM_TASK] Common variables

[DNM_TASK] Device running states

[DNM_TASK] Global state field

[DNM_TASK] Communication error

[DNM_TASK] Receive queue

[DNM_TASK] Transmit queue

[DNM_TASK] DeviceNet command counters

[DNM_TASK] Timeout counter

[DNM_TASK] Init counter

They are explained on the following pages:
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PLC_TASK Common variables

Dn6_12.bmp

Fig. 8-11: PLC_TASK Common variables

Variable Meaning

Version compiled Hardware

Task state Task state

Handshake counter Counter for the performed process data handshakes

Handshake mode This value represents the actual handshake mode between application and
CIF.

0 = Bus synchronous, Device controlled

1 = Buffered, Device controlled

2 = No consistence, Uncontrolled

3 = Buffered, Host controlled

4 = Bus synchronous, Host controlled

5 = Buffered, Extended host controlled
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DNM_TASK Common variables

Dn6_13.bmp

Fig. 8-12: DNM_TASK Common variables

Variable Meaning

Received messages Number of received CAN-messages

Sent messages Number of sent CAN-messages

Receive overruns This counter is incrementing, when to many incoming CAN messages
overload the master. An incremented counter will always cause lost CAN
message data, so it should normally contain the value 0.

Received overruns Our Hilscher DeviceNet controller has two internal error frame counters
for detection.

Low transmission quality If the internal DeviceNet controller error frame counter oversteps a
defined limit.

Bus off counter This number will increment, when the bus is off or not powered during bus
cycles.

Baudrate This numeric value shows the actual baudrate the master is working with
(1 = 500kBaud, 2 = 250Kbaud, 3 = 125kBaud).

Activated bus parameters Value 0, the master has found a configuration data base coming from
SyConDN, value 1, the master device isn’t configured and need to be
configured via SyConDN.

Announced devices This value represents the number of found device data sets in the
download database.

Wrong parameters This value indicates, if the master has detected errors in a device data
set, which was a containment of the actual downloaded database. For
each slave device having a wrong entry the counter is incremented by 1.

Hard transmission aborts This value indicates transmission aborts by the master.
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Device running states

Dn6_14.bmp

Fig. 8-13: Device running states

To handle the slave devices in their different states, the master device
has a slave device handler running, where each slave device has its own
actual running state. SyConDN interprets the actual state of each slave
and enters these states on the screen in textual form.
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Communication error

Dn6_15.bmp

Fig. 8-14: Communication error

For each slave device the master has an internal online error buffer.
SyConDN interprets the actual error state and prints it on the screen in
textual form.
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Receive queue

Dn6_16.bmp

Fig. 8-15: Receive queue

The Receive Queue is used to monitor the Receive Transmission Queue
of the internal CAN controller.

Variable Meaning

bRear A pointer to where the next message will be dequeued from the queue
body.

bFront A pointer to where the next message will be stored.

bInner The actual number of stored messages.
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Transmit queue

Dn6_17.bmp

Fig. 8-16: Transmit queue

The Transmit Queue is used to monitor the Transmit Transmission
Queue of the internal CAN controller.

Variable Meaning

bRear A pointer to where the next message will be dequeued from the queue
body.

bFront A pointer to where the next message will be stored.

bInner The actual number of stored messages.
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DeviceNet command counters

Dn6_18.bmp

Fig. 8-17: DeviceNet command counters

The DeviceNet Command Counters dialog box shows a listing of the
DeviceNet-specific commands used by the controller and there
associated usage count.
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Timeout counter

Dn6_19.bmp

Fig. 8-18: Timeout counter

The Timeout Counter shows the number of timeouts for each slave
device configured in the DeviceNet bus system.
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Init counter

Dn6_20.bmp

Fig. 8-19: Init counter

The Device Init Counter is always incremented, when the slave device is
initialized. Normally, the counter must show value 1 for each configured
slave, but if a slave is detected as inactive during the diagnostic
procedure, the master tries to reinitialize the slave again. If this happens,
the slave init counter is incremented by a value of 1. So, values larger
then 1 are an indication for communication errors to the corresponding
slave.
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Device (Slave)
The extended device diagnostic helps to find possible bus and
configuration faults, if SyConDN does not offer further support.

To activate the extended device diagnostic for Hilscher DeviceNet Slaves,
click with the right mouse button to the Slave and select the menu Select
as actual slave. Then, select the menu Online >Extended Device
Diagnostic (left mouse click). This menu item activates a list of available
diagnostic structures which contain parameters and counters to be
retrieved now.

Dn6_21.bmp

Fig. 8-20: Extended device diagnostic for Hilscher DeviceNet slave

The task states that are available for the DeviceNet master are:

• PLC_TASK] Common variables

• [DNS_TASK] Common variables

• [DNS_TASK] Receive queue

• [DNS_TASK] Transmit queue

They are explained on the following pages:
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PLC_Task Common variables

Dn6_22.bmp

Fig. 8-21: PLC_Task Common variables

Variable Meaning

Version compiled Hardware

Task state Task state

Handshake counter Counter for the performed process data handshakes

Handshake mode This value represents the actual handshake mode between application
and CIF.

0 = Bus synchronous, Device controlled

1 = Buffered, Device controlled

2 = No consistence, Uncontrolled

3 = Buffered, Host controlled

4 = Bus synchronous, Host controlled

5 = Buffered, Extended host controlled
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DNS_Task Common variables

Dn6_23.bmp

Fig. 8-22: DNS_Task Common variables

Variable Meaning

Received messages Number of received CAN-messages.

Sent messages Number of sent CAN-messages.

Received overruns Our DeviceNet controller has two internal error frame counters for
detection.

Low transmission quality If the internal DeviceNet Slave error frame counter oversteps a defined
limit.

Bus off counter This number will increment, when the bus is off or not powered during bus
cycles.

Baudrate This numeric value shows the actual baudrate the master is working with
(255 = Auto, 0 = 500kBaud, 1 = 250Kbaud, 2 = 125kBaud).

Activated bus parameters Value 0, the master has found a configuration data base coming from
SyConDN, value 1, the master device isn’t configured and needs to be
configured via SyConDN.

Hard transmission aborts This value indicates transmission aborts by the slave.
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Receive queue

Dn6_24.bmp

Fig. 8-23: Receive queue

The Receive Queue is used to monitor the Receive Transmission Queue
of the internal CAN controller.

Variable Meaning

BaseLow Undocumented.

BaseHigh Undocumented.

bNel Undocumented.

bWidth Undocumented.

bRear A pointer to where the next message will be dequeued from the queue
body.

bFront A pointer to where the next message will be stored.

bInner The actual number of stored messages.

fnUser Undocumented.
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Transmit queue

Dn6_25.bmp

Fig. 8-24: Transmit queue

The Transmit Queue is used to monitor the Transmit Transmission
Queue of the internal CAN controller.

Variable Meaning

BaseLow Undocumented.

BaseHigh Undocumented.

bNel Undocumented.

bWidth Undocumented.

bRear A pointer to where the next message will be dequeued from the queue
body.

bFront A pointer to where the next message will be stored.

bInner The actual number of stored messages.

fnUser Undocumented.
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8.4 User Data

I/O Monitor
This is an easy way of viewing and changing the first 32 bytes of the
process data image.

Dn6_26.bmp

Fig. 8-25: Online > I/O monitor

DEC/HEX converts the display of the input data. The output data are
always in decimal form.

Enter the output value and then press Update.

Always the first 32 input and output bytes of the process description are
shown, also when these bytes have not been occupied by the
configuration.

The display is always in a byte manner.

The I/O Watch Monitor described in the next section allows a more
comfortable display.
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I/O Watch
The I/O Watch monitor can be used in place of the I/O Monitor and offers
further features:

• Various data formats: Hex, Unsigned Decimal, Signed Decimal, Bit
Pattern

• The I/O Watch monitor works symbol-oriented.

• It is not necessary to know the offset addresses.

The following table lists the typical steps to use the I/O Watch monitor.

Preconditions:

• The project/configuration already exists, containing a DeviceNet
Master and the DeviceNet devices, as described in chapter
Configuration Sequence starting on page 5-1,

• The Configuration has been downloaded into the DeviceNet Master
using Online > Download,

• The bus system is running.

Proceed as follows:

1. Open the existing project using File > Open.

2. Open the Windows dropdown menu and select Window > Logical
Network View to change the window. A window with three sections
opens:

Left window Center window Right window

Project Tree structure Tag / Symbol IO Watch

3. Open the tree structure in the left window to reach the I/O module of
the desired device:

Project > Master > Device > Connection Type > Data Type

Dn6_27.bmp

Fig. 8-26: Logical network view and I/O watch
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4. If you select the desired module,  the tags/symbols will be displayed
in the center window of the Logical Network View.

5. Select with the left mouse button the tag/symbol desired and drag and
drop it in the right window of the Logical Network View (IO Watch).

6. Select in the right window the desired tag by clicking on the left
mouse button and open then a menu with the right mouse button.
Then, select Start from the context menu. A new window called I/O
Watch appears.

7. A table shows the Device, Symbolic Name, IEC Address (Offset),
Data Type, Representation and Value. Select the line with the desired
information. Click on Hex under Representation and select the way
the values are to be displayed. Choices are Hex, Decimal Unsigned,
Decimal Signed, Bit Pattern.

8. Input data are displayed and can’t be changed. Output data can be
entered into the value column.

Dn6_28.bmp

Fig. 8-27: I/O watch

To close this windows use Alt-F4 or click the icon in the upper left corner
of the window select Exit.
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8.5 DeviceNet Services

Get Device Attribute
This menu selection enables the user to get/receive attribute-related
information from a slave device. The user should be familiar with the
supported Class, Instance, and Attribute entries for the slave device.
These entries should be available within the suppliers data sheet for the
slave product. The return value will be represented in Hexadecimal.
Clicking the ASCII button will change this value to ASCII text. The
Hexadecimal code can be resorted by clicking now the Hex button.
Clicking the Get button will receive the Value from the device.

Dn6_29.bmp

Fig. 8-28: Get device attribute

Set Device Attribute
This menu selection enables the user to set attribute-related information
to a slave device. The user should be familiar with the supported Class,
Instance, and Attribute entries for the slave device. These entries should
be available within the suppliers data sheet for the slave product. The
Value will be represented in Hexadecimal. Clicking the Set button will
send the information to the slave device.

Dn6_30.bmp

Fig. 8-29: Set device attribute
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8.6 Message Monitor

The Message Monitor permits access to the mailbox of the CIF. The
usage of the  Message Monitor assumes advanced knowledge from the
user about the DeviceNet protocol.

First, chose the Hilscher device with a left mouse click on the symbol of
the Hilscher device. Then, call up the Online > Message Monitor menu.

Dn6_31.bmp

Fig. 8-30: Online > Message monitor

A message can be saved and retrieved and has the file suffix *.MSG.

File > New opens a new window.

File > Open opens an already saved message.

File > Save or File > Save as saves a message.

File > Exit ends the Message Monitor and returns to the SyConDN.

Edit > Create answer creates an answer message.

Edit > Reset counter resets all inputs.
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View > Review the received data: all received data is shown.

View > Review the send data: all send data is shown.

View > Number of receipt errors: the number of the receipt errors are
shown.

View > Decimal/Hexadecimal: switches the display format.

It is recommended to create a sub-directory MSG and to store the
messages there.

Dn6_32.bmp

Fig. 8-31: Save as
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Message Monitor for Testing the Explicit Messaging of DeviceNet
The following section describes the Message Monitor for getting data
from and setting data to the master via DeviceNet.

The following must be entered in the Message Monitor, in order to get
data form or set data to a device via DeviceNet:

Message header

Rx = 3 (always) Tx = 255

Ln = (is calculated) Nr = 0 .. 255

A = 0 F = 0

B = 17 E = 0

Telegram header Meaning for DeviceNet Value range

Device adr. MAC ID of the device 0 .. 63

Data area Class ID

Data address Instance ID

Data index Attribute ID

Data count Data count

Unused in read access

Length of attribute data in write
access

0

1 – 240

Data type Data type, unused 0

Function Read

Write

1

2

Fig. 8-32: Message Monitor – Example DeviceNet
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9 File, Print, Export and View

9.1 File

Open
An existing project can be opened with File > Open.

Save and Save As
When the file name is known, then the configuration can be saved under
the File > Save menu, otherwise the File > Save As menu must be
selected.

Close
The current project can be closed with File > Close.
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9.2 Print

After the current printer has been selected in the File > Printer Setup
menu, the configuration can be printed out under the File > Print menu.
For a page view, select the File > Page View menu.

Dn7_1.bmp

Fig. 9-1: File > Print

When you select the initial setting, the basic information for one device is
printed on one sheet. If you select

• Topology the basic information as well as the topology of the bus
system is printed,

• Bus parameters also the bus parameters of the bus system are
printed,

• Address table also the address table of the master is printed,

• Device table also the device table is printed.

The scope can be specified with the Device selection menu point. The
following options can be selected:

• All,

• From Station address to Station address,

• Selection of a device by means of its description.
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9.3 Export Functions

DBM Export
Select the File > Export > DBM menu in order to save the previously
saved project file (*.DN Microsoft Access Format) as a DBM file (Hilscher
binary format). This DBM file can be retrieved in the DOS Compro
program. The configuration is stored in the project directory in the path of
the SyConDN installation with the name >your project name>.DBM.

CSV Export
Select the File > Export > CSV menu in order to save the previously
saved project file (*.DN Microsoft Access Format) in a CSV file. This CSV
file can be edited with e.g. Excel. The configuration is stored in the project
directory in the path of the SyConDN installation with the name >your
project name>.DBM.

9.4 View of the Configuration

Device Table
The View > Device Table menu shows the list of all devices that have
been inserted.

Dn7_2.bmp

Fig. 9-2: View > Device table
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Address Table
A list of all addresses used in the process depiction is displayed in the
View > Address Table menu. For this purpose, the current master for
which the table is to be displayed must be chosen.

Addresses refer to the Master.

Dn7_3.bmp

Fig. 9-3: View > Address table
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10 Error Numbers

10.1 CIF Device Driver (Dual-Port Memory)
– Error Numbers (-1 ..-49)

This is the list of error numbers of Dual-Port Memory access using the
CIF Device Driver.

Error number Description

-1 Driver: Board not initialized

The communication board is not initialized by the driver.

No or wrong configuration found for the given board.

Check the driver configuration.

Driver function used without calling DevOpenDriver() first..

-2 Driver: Error in internal ‘Init state‘

-3 Driver: Error in internal ‘Read state‘

-4 Driver: Command on this channel is active

-5 Driver: Unknown parameter in function occurred

-6 Driver: Version is incompatible

The device driver version does not correspond to the driver DLL version. From version V1.200 the
internal command structure between DLL and driver has changed. Make sure to use the same
version of the device driver and the driver DLL.

-10 Device: Dual-Port Memory RAM not accessible (board not found)

Dual-ported RAM (DPM) not accessible / no hardware found.

This error occurs, when the driver is not able to read or write to the Dual-Port Memory.

Check if the BIOS setting of the PC Memory address are in conflict with other PC components.

Try another memory address.

Check the driver configuration for this board.

Check the jumper settings for this board.

-11 Device: Not ready (RDY flag=Ready flag failed)

Board is not ready. This could be a hardware malfunction or another program writes inadmissible
to the Dual-Port Memory.

-12 Device: Not running (RUN flag=Running flag failed)

The board is ready, but not all tasks are running, because of an initialization error. No data base is
loaded into the device or a wrong parameter can cause that a task can't initialize.

Fig. 10-1: Table of CIF Device Driver – Error numbers
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Error Number Description

-13 Device: Watch dog test failed

-14 Device: Signals wrong operating system version

No license code found on the communication board. Device has no license for the used operating
system or customer software. No firmware or no database on the device is loaded.

-15 Device: Error in Dual-Port Memory flags

-16 Device: Send mailbox is full

-17 Device: Function PutMessage timeout

No message could be send during the timeout period given in the DevPutMessage() function.

If you use an interrupt, then check the interrupt on the device and in driver setup. These settings
have to be the same! Is an interrupt on the board set? Is the right interrupt set? The interrupt could
already be used by another PC component, also if the operating system reports it as unused.

If you use polling mode, then make sure that no interrupt is set on the board and that polling is set
in the driver setup. These settings have to be the same!

Device internal segment buffer full and therefore PutMessage() function is not possible, because
all segments on the device are in use. This error occurs, when only PutMessage() is used but not
GetMessage HOST flag is not set for the device. No messages are taken by the device. Use
DevSetHostState() to signal a board an application is available.

-18 Device: Function GetMessage timeout

No message received during the timeout period given in the DevGetMessage() function.

If you use an interrupt, then check the interrupt on the device and in driver setup. These settings
have to be the same! Is an interrupt on the board set? Is the right interrupt set? The interrupt could
already be used by another PC component, also if the operating system reports it as unused.

If you use polling mode, then make sure that no interrupt is set on the board and that polling is set
in the driver setup. These settings have to be the same!

The used protocol on the device needs longer than the timeout period given in the
DevGetMessage() function.

-19 Device: No message available

Fig. 10-2: Table of CIF Device Driver – Error numbers
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Error number Description

-20 Device: Reset command timeout

The board is ready, but not all tasks are running, because of an initialization error. No data base is
loaded into the device or a wrong parameter can cause that a task can’t initialize.

The device needs longer than the timeout period given in the DevReset() function. Using device
interrupts. The timeout period can differ between fieldbus protocols.

If you use an interrupt, then check the interrupt on the device and in driver setup. These settings
have to be the same! Is an interrupt on the board set? Is the right interrupt set? The interrupt could
already be used by another PC component, also if the operating system reports it as unused.

If you use polling mode, then make sure that no interrupt is set on the board and that polling is set in
the driver setup. These settings have to be the same!

-21 Device: COM flag not set

The device can not reach communication state. Device not connected to the fieldbus. No station
found on the fieldbus. Wrong configuration on the device.

-22 Device: IO data exchange failed

-23 Device: IO data exchange timeout

The device needs longer than the timeout period given in the DevExchangeIO() function.

If you use an interrupt, then check the interrupt on the device and in driver setup. These settings
have to be the same! Is an interrupt on the board set? Is the right interrupt set? The interrupt could
already be used by another PC component, also if the operating system reports it as unused.

If you use polling mode, then make sure that no interrupt is set on the board and that polling is set in
the driver setup. These settings have to be the same!

-24 Device: IO data mode unknown

-25 Device: Function call failed

-26 Device: Dual-Port Memory size differs from configuration

-27 Device: State mode unknown

Fig. 10-3: Table of CIF Device Driver – Error numbers
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Error number Description

-30 User: Driver not opened (device driver not loaded)

The device driver could not be opened. Device driver not installed. Wrong parameters in the driver
configuration. If the driver finds invalid parameters for a communication board and no other boards
with valid parameters are available, the driver will not be loaded.

-31 User: Can’t connect with device board

-32 User: Board not initialized (DevInitBoard not called)

-33 User: IOCTRL function failed

A driver function could not be called. This is an internal error between the device driver and the DLL.
Make sure to use a device driver and a DLL with the same version. An incompatible old driver DLL is
used.

-34 User: Parameter DeviceNumber invalid

-35 User: Parameter InfoArea unknown

-36 User: Parameter Number invalid

-37 User: Parameter Mode invalid

-38 User: NULL pointer assignment

-39 User: Messagebuffer too short

-40 User: Size parameter invalid

-42 User: Size parameter with zero length

-43 User: Size parameter too long

-44 User: Device address null pointer

-45 User: Pointer to buffer is a null pointer

-46 User: SendSize parameter too long

-47 User: ReceiveSize parameter too long

-48 User: Pointer to send buffer is a null pointer

-49 User: Pointer to receive buffer is a null pointer

Fig. 10-4: Table of CIF Device Driver – Error number

1.000 If the operating system of the device reports an initialization error, then a value of 1000 will be add to
the error number and shown to the user.
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10.2 CIF Serial Driver – Error Numbers (-20 .. -71)

These is the list of error numbers using the serial driver.

Error number Description

-20 Driver: No COM port found or COM port already in use.

-21 Driver: COM port already opened

-22 Driver: Function call into driver has failed

-23 Driver: Internal driver error

-24 Driver: Could not create read thread

-25 Driver: Could not create read event

-26 Driver: Could not create write event

-27 Driver: Could not create timer event

-28 Driver: Error by writing data

-29 Driver: Wrong COM state

-30 Driver: COM state error is set

-31 Driver: COM buffer setup failed

-32 Driver: COM set timeout failed

-33 Driver: Receive buffer overrun

-34 Driver: Receive buffer full

-35 Driver: Send busy

-36 Driver: Error during close driver

-40 User: COM port not opened

-41 User: Invalid handle value

-42 User: Invalid COM number

-43 User: Size parameter invalid

-44 User: Size parameter zero

-45 User: Buffer pointer is NULL

-46 User: Buffer too short

-47 User: Setup error

Fig. 10-5: Table of CIF Serial Driver – Error numbers
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Error number Description

-50 User: Send message, timeout error

-51 User: Could not send a message

Cable not connected.

Wrong cable.

Device does not respond.

-52 User: Send message, no device connected

-53 User: Error by send message, message receiving

-54 User: Telegram collision

-55 User: Telegram, no acknowledgement received

-56 User: Telegram, noise

-57 User: Telegram, data overrun

-58 User: Telegram, parity error

-59 User: Telegram, framing error

-60 User: Telegram, unknown error

-70 User: Timeout by receiving a message

-71 User: No message received

Fig. 10-6: Table of CIF Serial Driver – Error numbers
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10.3 RCS – Error Numbers (4 .. 93)

This is the list of error numbers returned by the RCS (Realtime
Communication System), that is the operating system of Hilscher devices.
The error number is returned in an answer message. Command
messages and answer messages are used to communicate between the
application software (e.g. the system configurator) and the Hilscher
device. An example of this communication is the download of a
configuration.

Error number Description

4 Task does not exist

5 Task is not initialized

6 The MCL is locked

7 The MCL rejects a send command because of an error

20 The user will download a database into the device that is not valid for this device type

21 Database segment not configured or not existent

22 Number for message wrong during download

23 Received number of data during download does not match to that in the command message

24 Sequence identifier wrong during download

25 Checksum after download and checksum in command message do not match

26 Write/Read access of data base segment

27 Download/Upload or erase of configured data base type is not allowed

28 The state of the data base segment indicated an error. Upload not possible

29 The access to the data base segment needs the bootstraploader. The bootstraploader is not present

30 Trace buffer overflow

31 Entry into trace buffer too long

37 No or wrong license. The OEM license of the system configurator allows only communication to
devices that have the same license inside

38 The data base created by the system configurator and the data base expected by the firmware is not
compatible

39 DBM module missing

Fig. 10-7: Table of RCS (answer message) – Error numbers
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Error number Description

40 No command free

41 Command unknown

42 Command mode unknown

43 Wrong parameter in the command

44 Message length does not match to the parameters of the command

45 Only a MCL is allowed to transfer this command to the RCS

50 FLASH occupied at the moment

51 Error deleting the FLASH

52 Error writing the FLASH

53 FLASH not configured

54 FLASH timeout error

55 Access protection error while deleting the FLASH

56 FLASH size does not match or not enough FLASH memory

60 Wrong structure type when accessing a task structure

61 Wrong structure length when accessing a structure

62 Structure does not exist

70 No clock on the device

80 Wrong handle for the table (table does not exist)

81 Data length does not match the structure of this table

82 The data set of this number does not exist

83 This table name does not exist

84 Table full. No more entries allowed

85 Other error from DBM

90 The device info (serial number, device number and date) does already exist

91 License code invalid

92 License code does already exist

93 All memory locations for license codes already in use

Fig. 10-8: Table of RCS (answer message) – Error numbers
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10.4 Database Access – Error Numbers (100 .. 130)

The following table lists the error numbers of the database access errors.

Error number Description

100 Database already opened

101 Data set could not be opened

103 Error while opening database occurred

104 No valid path name

105 No connection to data base. Call function DbOpen().

106 Error in parameter

107 Error during opening a table

108 Inadmissible nullpointer occurred

109 Table not opened. Call function OpenTable() first.

110 The first data set is reached

111 The last data set is reached

112 Unknown type in the data set found

113 Data has to be truncated

114 No access driver installed on the system

115 Exception received

116 This table is set to read only

117 There is no data set in the table

118 The requested table can not be edited

119 An operation could not be completed

120 User gives an unexpected length in WritsDs().

121 An assertion failed

122 DLL not found

123 DLL couldn’t be freed

124 Specified function not found in the DLL

125 ODBC Function returns an error number

126 Count of data bytes in the data set exceeds 1938 bytes

127 DBM32 DLL is not loaded

128 Field with the given index was not found

129 This table contains no data set

130 Invalid character (’ ’) found in a table or column

Fig. 10-9: Database access – Error numbers
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10.5 Online Data Manager – Error Numbers

Online Data Manager – Error Numbers (1000 .. 1018)
The following table lists the error numbers of the Online Data Manager.

Error number Description

1000 Driver OnlineDataManager not opened

1001 Initialization of the OnlineDataManager has failed

1002 No DriverObject found. OnlineDataManager Sub DLL not found.

1003 No DeviveObject found. Device not found.

1004 Application not found

1010 Application has requested an unknown event

1011 Application has requested an unknown function mode, operating mode. Known function modes,
operating modes are Reset, Download, Register Server, Unregister Server.

1012 Application has requested an unknown command.

1013 Message Server already exists

1014 Message Server not registered

1015 Device already in use

1016 Device not assigned

1017 Device has changed

1018 Command already active

Fig. 10-10: Table of the Online Data Manager – Error numbers

Message Handler – Error Numbers (2010 .. 2027)
The following table lists the error numbers of the message handler of the
Online Data Manager.

Error Number Description

2010 Message Handler: Message buffer empty

2011 Message Handler: Message buffer full

2021 Message Handler: Invalid Message ID (msg.nr)

2022 Message Handler: No entry

2023 Message Handler: Message already active

2024 Message Handler: Wrong Application

2025 Message Handler: Message Timeout

2026 Message Handler: Wait for Delete

2027 Message Handler: No cyclic message

Fig. 10-11: Table of Message Handler – Error numbers of the Online Data
Manager
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Driver Functions – Error Numbers (2501 .. 2512)
The following table lists the error numbers of the driver functions of the
Online Data Manager.

Error number Description

2501 OnlineDataManager Sub-DLL not found

2502 Function missing

2503 ’Read Thread’ not created

2504 ’Write Thread’ not created

2505 ’IO Thread’ not created

2510 Function failed

2512 Assignment reports error. Return neither OK nor cancel.

Fig. 10-12: Table of driver functions – Error numbers of the Online Data
Managers

Online Data Manager Subfunctions – Error Numbers (8001 .. 8035)
The following table lists the error numbers of the subfunctions of the
Online Data Manager.

Error number Description

8001 Driver not opened. E.g. CIF Devive Driver

8002 Application has requested an unknown event

8003 Application has requested an unknown command

8004 Command has failed

8005 Command active

8006 Device invalid

8010 No device was assigned

8011 Device was already assigned

8020 Driver not connected

8021 Driver already connected

8030 Faulty ’GetState’

8031 Send error (PutMessage returns error)

8032 Send active (PutMessage active)

8033 Receive error (GetMessage returns error)

8034 Receive active (GetMessage active)

8035 IO Error (ExchangeIO returns error)

Fig. 10-13: Table of the subfunctions – Error numbers of the Online Data
Managers



10-12 Error Numbers SyConDN

           DOK-CONTRL-SYCON****DN-AW02-EN-P

10.6 Database – Error Numbers (4000 .. 4098)

The following table lists the error numbers of the converting functions.

Error number Description

4000 File does not exist

4001 Success in packing

4002 Data set does not exist

4003 Last respectively first entry reached

4004 Not enough memory

4005 File directory full

4006 Max. number of entries reached

4007 No writing to this table possible, because the table is located in the FLASH

4008 Table name does already exist

4009 File name does not exist

4010 Free RAM length from RCS_CNF.P86 is smaller than E_F_INDEX * 2

4011 Parameter ‘next’ wrong

4012 Not enough free space to copy data set

4013 Set is deleted

4014 Value for index is wrong

4015 Access not allowed

4016 open_file used before init_file

4017 Drive is not ready or available

4018 Not enough drive memory

4019 File name or path does not exist

4020 Cannot create path

4021 Wrong path

4022 Wrong flag

4023 The delete path is the root path

4024 Path or file name exists

4025 Write error during writing a file

4026 Error during creating a file

4027 Error during closing a file

4028 No DBM file

4029 Length of the read data is unequal of the file length

Fig. 10-14: Table database – Error numbers
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Error number Description

4030 Path too long

4031 Directory changed

4032 Directory created

4034 Length of converting stream is 0

4035 Non-equal data set found

4036 Not allowed to write set 0

4037 No entry in this file

4038 Data set has length 0

4039 The function DbmInit has assigned a zero pointer during RCS initialization

4040 Printer not ready

4041 The data base is used from an other function

4042 New length of data base is smaller than used

4043 Unknown access mode

4044 Old data base has to be converted

4045 Error while converting. Function not known

4046 Unknown type in set 0 found

4047 No float-function available

4048 Function not in RCS module

4049 Check failed

4050 Checksum check failed

4051 More segments are existing in file, than entries in the structure FILE_INFO_T in wMax

4052 SegLen in structure FILE_INFO_T is smaller then the length in the file. Return of function
dbm_restore_data

4053 The header file holds another information for a length than in the segment itself

4054 Not enough memory for allocation on the PC

4055 No index for file handle in structure FLASH_DIR of RCS found

4056

4057 File type 2 can not be printed, because of too many definitions

4058 The definitions need too many lines to display them, than in the program available

4059 An unknown format for the parameter. Valid is U, H, or S

4060 Unknown parameter type

Fig. 10-15: Table database – Error number
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Error number Description

4061 The data base was transmitted into the FLASH

4062 Set 0 contains no structure definition

4063 Set 0 can not be deleted

4064 Error during execution of an ODBC data base access

4065 Initializing of DBM through RCS had no success

4066 Passed data length incorrect

4067 Sorting function not linked

4068 Error in function parameter

4069 Error from ODBC table

4070 No free handle available. Too many data base links are already opened

4071 Unknown data type found in the table

4072 Structure of table GLOBAL not correct or no such table existing

4073 No name of an ACCESS data base

4074 Download window can’t be created

4075 Download not fully performable

Fig. 10-16: Table database – Error numbers
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Error number Description

4082 More than 32 tables should be created

4083 No entry in element szSourceFile

4084 ODBC connection initialization not possible. This could happen when in file ODBCINST.INI in section
[Microsoft Access Driver (*.mdb)] is no valid path to ODBCJT16/32.DLL.

4085 Error in structure in the ACCESS data base that is in DBM format.

4086 Error in structure in the ACCESS data base that is in DBM format.

4087 No database in a ODBC table

4088 No entry

4089 ODBC set length not valid

4090 Not enough data sets in ODBC table

4091 Table CreateTab not found

4092 Error in structure of table CreateTab

4093 No entry in element szSourceTable

4094 No entry in element szDestTable

4095 Entry in iSourceType of table CreateTab is wrong

4096 Entry in iTranslate of table CreateTab is wrong

4097 Function SQLAllocStmt reports an error

4098 ODBC source table not found

4099 ODBC data truncated

4100 Download timeout

4101 Library load error

4102 Library function error

4103 Error in description ’toggle’

4104 Error in description ’KB’

4105 Column does not exist

4106 ODBC structure different

4107 ODBC address error

4108 No CRC sum exists (table GLOBAL exists or old)

4109 Table GLOBAL is old

4110 Calculated CRC different to CRC in table GLOBAL

4199 Programming error

Fig. 10-17: Table of database – Error numbers
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10.7 Converting Functions – Error Numbers (5001 .. 5008)

The following table lists the error numbers of converting functions.

Error number Description

5000 Function PackLongToByteShort: Not enough space in pvD (Number of elements greater than
reserved memory)

5001 Function PackLongToByteShort: Not enough space in pvD. Detected during converting of pvS

5002 Function PackLongToByteShort: Not enough space in pvD

5003 Function StringToByte: Not enough space in pvD

5004 Function IntToByte: Not enough space in pvD

5005 Function LongToShort: Not enough space in pvD

5006 Function PackStringDumpToByteArray: Not enough space in pvD

5007 Function PackStringBumpToByteArray: A character was found, which is not convertible into a HEX
value

5008 Function PackStringDumpToByteArray: Number of character odd

5009 Function PackStringDumpToByteArray: Not enough space in pvD

5010 Function PackStringDumpToByteArray: The current data set needs to be appended the previous one

5011 Function PackStringDumpToByteArray: No corresponding function to the given number exist

5012 Converting error

Fig. 10-18: Table of the converting functions – Error numbers
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11 Description of the Dual-Port Memory DPM

11.1 General Information

For data exchange between the PLC and the DeviceNet connection a
Dual-Port Memory DPM of size 8 kbyte is available on the controller
board. It is divided up as follows:

512 bytes outputs

512 bytes inputs

Send mailbox

Parameter and
status information

Handshakebytes
for synchronization

PLC DPM on DeviceNet controller board DeviceNet

Receive mailbox

Aufteilung_DPM.FH7

Aufteilung_DPM.FH7

Fig. 11-1: Overview Dual-Port Memory

11.2 Memory Distribution DPM

In the PLC programming interface there is the possibility to access all
memory areas via absolute addressing. The corresponding variables
have to be entered in the VAR area of the declaration editor (e.g..:
variable AT %PB*.*). The following tables specify the addresses of the
single memory areas.

Address area
(decimal)

Address area
(hexadecimal)

Size Designation

0 - 511 0000 - 01FF 512 bytes

SndPd

Process output data

PLC Å DeviceNet

512 - 3583 0200 - 00DFF 3 kbyte Free

3584 - 4095 0E00 - 0FFF 512 bytes

RecvPd

Process input data

DeviceNet Å PLC

4096 - 7167 1000H - 1BFF 3 kbyte Free

Fig. 11-2: Addresses of the DP Master input and output data
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Address area
(decimal)

Address area
(hexadecimal)

Size Designation

0 - 6143 0000 - 17FF 6 kbyte Free

6144 - 6655 1800 -19FF 512 bytes

SndPd
Process output data
PLC Å DeviceNet

6656 - 7167 1A00 -1BFF 512 bytes

RecvPd
Process output data
DeviceNet Å PLC

Fig. 11-3: Addresses of the DP Slave input and output data

Address area
(hexadecimal)

Size Designation

1C00H -1D1FH 288 bytes DevMailbox[288] Message Buffer
HOST → DEVICE

1D20H-1D23H 4 bytes Date[4] Information Device

1D24H-1D27H 4 bytes DeviceNumber[4]

1D28H-1D2BH 4 bytes SerialNumber[4]

1D2CH-1D2FH 4 bytes reserved[4]

1D30H-1D33H 4 bytes PcOsName0[4] Information Driver

1D34H-1D37H 4 bytes PcOsName1[4]

1D38H-1D3BH 4 bytes PcOsName2[4]

1D3CH-1D3FH 4 bytes OemIdentifier[4]

1D40H-1E5FH 288 bytes
HostMailbox[288]
Message Buffer

DEVICE → HOST

1E60H-1E6FH 16 bytes FirmwareName[16]
Information Firmware

1E70H-1E7FH 16 bytes FirmwareVersion[16]

1E80H-1EBFH 64 bytes Task1Parameter[64]
Parameters of Task 1, 2

1EC0H-1EFFH 64 bytes Task2Parameter[64]

1F00H-1F3FH 64 bytes Task1State[64]

States of Task 1, 2

1F40H-1F7FH 64 bytes Task2State[64]

1F80H-1F87H 8 bytes Task1Name[8]
Information Task 1

1F88H integer Task1Version

1F8AH byte Task1State

1F8BH-1F8FH bytes reserved5

1F90H-1F97H bytes Task2Name[8] 8
Information Task 2

1F98H integer Task2Version

1F9AH byte Task2Condition

1F9BH-1F9FH bytes reserved5

1FA0H-1FA7H 8 bytes Task3Name[8]
Information Task 3

1FA8H integer Task3Version
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Address area
(hexadecimal)

Size Designation

1FAAH byte Task3Condition

1FABH-1FAFH bytes reserved5

1FB0H-1FB7H 8 bytes Task4Name[8]
Information Task 4

1FB8H Integer Task4Version

1FBAH byte Task4Condition

1FBBH-1FBFH bytes reserved5

1FC0H-1FC7H 8 bytes Task5Name[8]
Information Task 5

1FC8H integer Task5Version

1FCAH byte Task5Condition

1FCBH-1FCFH bytes reserved5

1FD0H-1FD7H bytes Task6Name[8] 8
Information Task 6

1FD8H integer Task6Version

1FDAH byte Task6Condition

1FDBH-1FDFH Bytes reserved5

1FE0H-1FE7H 8 bytes Task7Name[8]
Information Task 7

1FE8H integer Task7Version

1FEAH byte Task7Condition

1FEBH-1FEFH bytes reserved5

1FF0H integer RcsVersion
Information Operating System

1FF2H byte RcsError

1FF3H byte HostWatchDog

1FF4H byte DevWatchDog

1FF5H byte SegmentCount

1FF7H byte DriverType

1FF8H byte DpmSize
Information of the Device

1FF9H byte DevType

1FFAH byte DevModel

1FFBH-7FDH 3 bytes DevIdentifier[3]

1FFEH byte
HostFlags

Command and Acknowledge Location
DEVICE → HOST

1FFFH byte
DevFlags

Command and Acknowledge Location
HOST → DEVICE

Fig. 11-4: Address DP Master/Slave
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The memory areas have the following function:

In this memory area you will find the process data to be send.

In this memory area you will find the received process data.

The data to be send to the controller board are written in this memory
area.

In this memory area the messages send from the controller board are
available in a defined message format.

This two memory areas allow the mutual monitoring between the PLC
user program (HOST) and the controller board (DEVICE). For this, the
controller board retrieves the value of the DevWatchDog, increments this
value and writes the increased value back in the HostWatchDog. A value
of 255 is not incremented to 0, but to 1. The operation incrementing and
writing back is executed within 20 ms. The monitoring is only active, when
the value in the DevWatchDog is unequal to 0. After initializing the
controller board the value in the DevWatchDog is 0, so that the monitoring
function is deactivated. Thus, the user can switch on or off this monitoring
via the PLC program.

Number of still available memory segments to receive buffered
messages. This value is entered by the controller board.

Monitoring of data exchange between host and controller board. The
controller board describes the HostFlags; the host only retrieves the
HostFlags. The host describes the DevFlags; the controller board
retrieves the DevFlags.

SndPd:

RecvPd:

DevMailbox:

HostMailbox:

HostWatchDog/DevWatchDog:

SegmentCount:

HostFlags/DevFlags:
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13 Service & Support

13.1 Helpdesk

Unser Kundendienst-Helpdesk im Hauptwerk Lohr
am Main steht Ihnen mit Rat und Tat zur Seite.
Sie erreichen uns

Our service helpdesk at our headquarters in Lohr am
Main, Germany can assist you in all kinds of inquiries.
Contact us

- telefonisch - by phone: 49 (0) 9352 40 50 60
über Service Call Entry Center Mo-Fr   07:00-18:00
- via Service Call Entry Center Mo-Fr 7:00 am - 6:00 pm

- per Fax - by fax: +49 (0) 9352 40 49 41

- per e-Mail - by e-mail: service@boschrexroth.de

13.2 Service-Hotline

Außerhalb der Helpdesk-Zeiten ist der Service
direkt ansprechbar unter

After helpdesk hours, contact our service
department directly at

+49 (0) 171 333 88 26

oder - or +49 (0) 172 660 04 06

13.3 Internet

Unter www.boschrexroth.de finden Sie
ergänzende Hinweise zu Service, Reparatur und
Training sowie die aktuellen Adressen *) unserer
auf den folgenden Seiten aufgeführten Vertriebs-
und Servicebüros.

Verkaufsniederlassungen

Niederlassungen mit Kundendienst

Außerhalb Deutschlands nehmen Sie bitte zuerst Kontakt mit
unserem für Sie nächstgelegenen Ansprechpartner auf.

*) Die Angaben in der vorliegenden Dokumentation können
seit Drucklegung überholt sein.

At www.boschrexroth.de you may find
additional notes about service, repairs and training
in the Internet, as well as the actual addresses *)
of our sales- and service facilities figuring on the
following pages.

sales agencies

offices providing service

Please contact our sales / service office in your area first.

*) Data in the present documentation may have become
obsolete since printing.

13.4 Vor der Kontaktaufnahme... - Before contacting us...

Wir können Ihnen schnell und effizient helfen wenn
Sie folgende Informationen bereithalten:

1. detaillierte Beschreibung der Störung und der
Umstände.

2. Angaben auf dem Typenschild der
betreffenden Produkte, insbesondere
Typenschlüssel und Seriennummern.

3. Tel.-/Faxnummern und e-Mail-Adresse, unter
denen Sie für Rückfragen zu erreichen sind.

For quick and efficient help, please have the
following information ready:

1. Detailed description of the failure and
circumstances.

2. Information on the type plate of the affected
products, especially type codes and serial
numbers.

3. Your phone/fax numbers and e-mail address,
so we can contact you in case of questions.
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13.5 Kundenbetreuungsstellen - Sales & Service Facilities

Deutschland – Germany vom Ausland: (0) nach Landeskennziffer weglassen!
from abroad: don’t dial (0) after country code!

Vertriebsgebiet Mitte
 Germany Centre

Rexroth Indramat GmbH
Bgm.-Dr.-Nebel-Str. 2 / Postf. 1357
97816 Lohr am Main / 97803 Lohr

Kompetenz-Zentrum Europa

Tel.: +49 (0)9352 40-0
Fax: +49 (0)9352 40-4885

S E R V I C E

C A L L  E N T R Y  C E N T E R
MO – FR

von 07:00 - 18:00 Uhr

from 7 am – 6 pm

Tel. +49 (0) 9352 40 50 60
service@boschrexroth.de

S E R V I C E

H O T L IN E
MO – FR

von 17:00 - 07:00 Uhr
from 5 pm - 7 am

+ SA / SO

Tel.: +49 (0)172 660 04 06
o d e r  /  o r

Tel.: +49 (0)171 333 88 26

S E R V I C E

ERSATZTEILE / SPARES
verlängerte Ansprechzeit
- extended office time -

♦ nur an Werktagen
- only on working days -

♦ von 07:00 - 18:00 Uhr
- from 7 am - 6 pm  -

Tel. +49 (0) 9352 40 42 22

Vertriebsgebiet Süd
 Germany South

Rexroth Indramat GmbH
Landshuter Allee 8-10
80637 München

Tel.: +49 (0)89 127 14-0
Fax: +49 (0)89 127 14-490

Vertriebsgebiet West
 Germany West

Bosch Rexroth AG
Regionalzentrum West
Borsigstrasse 15
40880 Ratingen

Tel.: +49 (0)2102 409-0
Fax: +49 (0)2102 409-406

Gebiet Südwest
 Germany South-West

Bosch Rexroth AG
Service-Regionalzentrum Süd-West
Siemensstr.1
70736 Fellbach

Tel.: +49 (0)711 51046–0
Fax: +49 (0)711 51046–248

Gebiet Südwest
 Germany South-West

Bosch Rexroth AG
Regionalzentrum Südwest
Ringstrasse 70    /   Postfach 1144
70736 Fellbach   /    70701 Fellbach

Tel.: +49 (0)711 57 61–100
Fax: +49 (0)711 57 61–125

Vertriebsgebiet Nord
 Germany North

Bosch Rexroth AG
Walsroder Str. 93
30853 Langenhagen

Tel.: +49 (0) 511 72 66 57-0
Service: +49 (0) 511 72 66 57-256
Fax: +49 (0) 511 72 66 57-93
Service: +49 (0) 511 72 66 57-95

Vertriebsgebiet Mitte
 Germany Centre

Bosch Rexroth AG
Regionalzentrum Mitte
Waldecker Straße 13
64546 Mörfelden-Walldorf

Tel.: +49 (0) 61 05 702-3
Fax: +49 (0) 61 05 702-444

Vertriebsgebiet Ost
 Germany East

Bosch Rexroth AG
Beckerstraße 31
09120 Chemnitz

Tel.: +49 (0)371 35 55-0
Fax: +49 (0)371 35 55-333

Vertriebsgebiet Ost
 Germany East

Bosch Rexroth AG
Regionalzentrum Ost
Walter-Köhn-Str. 4d
04356 Leipzig

Tel.: +49 (0)341 25 61-0
Fax: +49 (0)341 25 61-111
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Europa (West) - Europe (West)

vom Ausland: (0) nach Landeskennziffer weglassen, Italien: 0 nach Landeskennziffer mitwählen
from abroad:    don’t dial (0) after country code, Italy:    dial 0 after country code

Austria - Österreich

Bosch Rexroth GmbH
Bereich Indramat
Stachegasse 13
1120 Wien

Tel.: +43 (0)1 985 25 40
Fax: +43 (0)1 985 25 40-93

Austria – Österreich

Bosch Rexroth GmbH
Gesch.ber. Rexroth Indramat
Industriepark 18
4061 Pasching

Tel.: +43 (0)7221 605-0
Fax: +43 (0)7221 605-21

Belgium - Belgien

Bosch Rexroth AG
Electric Drives & Controls
Industrielaan 8
1740 Ternat
Tel.: +32 (0)2 5830719
- service: +32 (0)2 5830717
Fax: +32 (0)2 5830731
 indramat@boschrexroth.be

Denmark - Dänemark

BEC A/S
Zinkvej 6
8900 Randers

Tel.: +45 (0)87 11 90 60
Fax: +45 (0)87 11 90 61

Great Britain – Großbritannien

Bosch Rexroth Ltd.
Rexroth Indramat Division
Broadway Lane, South Cerney
Cirencester, Glos GL7 5UH

Tel.: +44 (0)1285 863000
Fax: +44 (0)1285 863030
 sales@boschrexroth.co.uk
 service@boschrexroth.co.uk

Finland - Finnland

Bosch Rexroth Oy
Rexroth Indramat division
Ansatie 6
017 40 Vantaa

Tel.: +358 (0)9 84 91-11
Fax: +358 (0)9 84 91-13 60

France - Frankreich

Bosch Rexroth S.A.
Division Rexroth Indramat
Avenue de la Trentaine
(BP. 74)
77503 Chelles Cedex

Tel.: +33 (0)164 72-70 00
Fax: +33 (0)164 72-63 00
Hotline: +33 (0)608 33 43 28

France - Frankreich

Bosch Rexroth S.A.
Division Rexroth Indramat
ZI de Thibaud, 20 bd. Thibaud
(BP. 1751)
31084 Toulouse

Tel.: +33 (0)5 61 43 61 87
Fax: +33 (0)5 61 43 94 12

France - Frankreich

Bosch Rexroth S.A.
Division Rexroth Indramat
91, Bd. Irène Joliot-Curie
69634 Vénissieux – Cedex
Tel.: +33 (0)4 78 78 53 65
Fax: +33 (0)4 78 78 53 62

Italy - Italien

Bosch Rexroth S.p.A.
Via G. Di Vittoria, 1
20063 Cernusco S/N.MI

Tel.: +39 02 92 365 1
+39 02 92 365 326

Fax: +39 02 92 365 500
+39 02 92 365 516378

Italy - Italien

Bosch Rexroth S.p.A.
Via Paolo Veronesi, 250
10148 Torino

Tel.: +39 011 224 88 11
Fax: +39 011 224 88 30

Italy - Italien

Bosch Rexroth S.p.A.
Via del Progresso, 16 (Zona Ind.)
35020 Padova

Tel.: +39 049 8 70 13 70
Fax: +39 049 8 70 13 77

Italy - Italien

Bosch Rexroth S.p.A.
Via Mascia, 1
80053 Castellamare di Stabia NA

Tel.: +39 081 8 71 57 00
Fax: +39 081 8 71 68 85

Italy - Italien

Bosch Rexroth S.p.A.
Viale Oriani, 38/A
40137 Bologna

Tel.: +39 051 34 14 14
Fax: +39 051 34 14 22

Netherlands – Niederlande/Holland

Bosch Rexroth B.V.
Kruisbroeksestraat 1
(P.O. Box 32)
5281 RV Boxtel
Tel.: +31 (0)411 65 19 51
Fax: +31 (0)411 65 14 83
 www.boschrexroth.nl

Netherlands - Niederlande/Holland

Bosch Rexroth Services B.V.
Technical Services
Kruisbroeksestraat 1
(P.O. Box 32)
5281 RV Boxtel
Tel.: +31 (0)411 65 19 51
Fax: +31 (0)411 67 78 14
services@boschrexroth.nl

Norway - Norwegen

Bosch Rexroth AS
Rexroth Indramat Division
Berghagan 1          or: Box 3007
1405 Ski-Langhus     1402 Ski

Tel.: +47 (0)64 86 41 00
Fax: +47 (0)64 86 90 62
 jul.ruud@rexroth.no

Spain - Spanien

Bosch Rexroth S.A.
Divisiòn Rexroth Indramat
Centro Industrial Santiga
Obradors s/n
08130 Santa Perpetua de Mogoda
Barcelona
Tel.: +34 9 37 47 94 00
Fax: +34 9 37 47 94 01

Spain – Spanien

Goimendi S.A.
División Rexroth Indramat
Parque Empresarial Zuatzu
C/ Francisco Grandmontagne no.2
20018 San Sebastian

Tel.: +34 9 43 31 84 21
- service: +34 9 43 31 84 56
Fax: +34 9 43 31 84 27
- service: +34 9 43 31 84 60
 sat.indramat@goimendi.es

Sweden - Schweden

Rexroth Mecman Svenska AB
Rexroth Indramat Division
- Varuvägen 7
(Service: Konsumentvägen 4, Älfsjö)
125 81 Stockholm

Tel.: +46 (0)8 727 92 00
Fax: +46 (0)8 647 32 77

Sweden - Schweden

Rexroth Mecman Svenska AB
Indramat Support
Ekvändan 7
254 67 Helsingborg
Tel.: +46 (0) 42 38 88 -50
Fax: +46 (0) 42 38 88 -74

Switzerland West - Schweiz West

Bosch Rexroth Suisse SA
Département Rexroth Indramat
Rue du village 1
1020 Renens
Tel.: +41 (0)21 632 84 20
Fax: +41 (0)21 632 84 21

Switzerland East - Schweiz Ost

Bosch Rexroth Schweiz AG
Geschäftsbereich Indramat
Hemrietstrasse 2
8863 Buttikon
Tel. +41 (0) 55 46 46 111
Fax +41 (0) 55 46 46 222
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Europa (Ost) - Europe (East)

vom Ausland: (0) nach Landeskennziffer weglassen  
from abroad:    don’t dial (0) after country code

Czech Republic - Tschechien

Bosch -Rexroth, spol.s.r.o.
Hviezdoslavova 5
627 00 Brno

Tel.: +420 (0)5 48 126 358
Fax: +420 (0)5 48 126 112

Czech Republic - Tschechien

DEL a.s.
Strojírenská 38
591 01 Zdar nad Sázavou
Tel.: +420 566 64 3144
Fax: +420 566 62 1657

Hungary - Ungarn

Bosch Rexroth Kft.
Angol utca 34
1149 Budapest

Tel.: +36 (1) 422 3200
Fax: +36 (1) 422 3201

Poland – Polen

Bosch Rexroth Sp.zo.o.
ul. Staszica 1
05-800 Pruszków

Tel.: +48 22 738 18 00
– service: +48 22 738 18 46
Fax: +48 22 758 87 35
– service: +48 22 738 18 42

Poland – Polen

Bosch Rexroth Sp.zo.o.
Biuro Poznan
ul. Dabrowskiego 81/85
60-529 Poznan

Tel.: +48 061 847 64 62 /-63
Fax: +48 061 847 64 02

Romania - Rumänien

East Electric S.R.L.
B-dul Basarabie, nr.250, sector 3
73429 Bucuresti

Tel./Fax:: +40 (0)21 255 35 07
+40 (0)21 255 77 13

Fax: +40 (0)21 725 61 21
 est@mb.roknet.ro

Romania - Rumänien

Bosch Rexroth Sp.zo.o.
Str. Drobety nr. 4-10, app. 14
70258 Bucuresti, Sector 2

Tel.: +40 (0)1 210 48 25
+40 (0)1 210 29 50

Fax: +40 (0)1 210 29 52

Russia - Russland

Bosch Rexroth OOO
Wjatskaja ul. 27/15
127015 Moskau

Tel.: +7-095-785 74 78
+7-095 785 74 79

Fax: +7 095 785 74 77
 laura.kanina@boschrexroth.ru

Russia - Russland

ELMIS
10, Internationalnaya
246640 Gomel, Belarus
Tel.: +375/ 232 53 42 70

+375/ 232 53 21 69
Fax: +375/ 232 53 37 69
 elmis_ltd@yahoo.com

Turkey - Türkei

Bosch Rexroth Otomasyon
San & Tic. A..S.
Fevzi Cakmak Cad No. 3
34630 Sefaköy Istanbul
Tel.: +90 212 541 60 70
Fax: +90 212 599 34 07

Slowenia - Slowenien

DOMEL
Otoki 21
64 228 Zelezniki
Tel.: +386 5 5117 152
Fax: +386 5 5117 225
 brane.ozebek@domel.si
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Africa, Asia, Australia – incl. Pacific Rim

Australia - Australien

AIMS - Australian Industrial
Machinery Services Pty. Ltd.
28 Westside Drive
Laverton North Vic 3026
Melbourne

Tel.: +61 3 93 243 321
Fax: +61 3 93 243 329
Hotline: +61 4 19 369 195
 terryobrien@aimservices.com.au

Australia - Australien

Bosch Rexroth Pty. Ltd.
No. 7, Endeavour Way
Braeside Victoria, 31 95
Melbourne

Tel.: +61 3 95 80 39 33
Fax: +61 3 95 80 17 33
 mel@rexroth.com.au

China

Shanghai Bosch Rexroth
Hydraulics & Automation Ltd.
Waigaoqiao, Free Trade Zone
No.122, Fu Te Dong Yi Road
Shanghai 200131 - P.R.China

Tel.: +86 21 58 66 30 30
Fax: +86 21 58 66 55 23
richard.yang_sh@boschrexroth.com.cn
 gf.zhu_sh@boschrexroth.com.cn

China

Shanghai Bosch Rexroth
Hydraulics & Automation Ltd.
4/f, Marine Tower
No.1, Pudong Avenue
Shanghai 200120 - P.R.China

Tel: +86 21 68 86 15 88
Fax: +86 21 58 40 65 77

China

Bosch Rexroth China Ltd.
15/F China World Trade Center
1, Jianguomenwai Avenue
Beijing 100004, P.R.China

Tel.: +86 10 65 05 03 80
Fax: +86 10 65 05 03 79

China

Bosch Rexroth China Ltd.
Guangzhou Repres. Office
Room 1014-1016, Metro Plaza,
Tian He District, 183 Tian He Bei Rd
Guangzhou 510075, P.R.China

Tel.: +86 20 8755-0030
+86 20 8755-0011

Fax: +86 20 8755-2387

China

Bosch Rexroth (China) Ltd.
A-5F., 123 Lian Shan Street
Sha He Kou District
Dalian 116 023, P.R.China

Tel.: +86 411 46 78 930
Fax: +86 411 46 78 932

China

Melchers GmbH
BRC-SE, Tightening & Press-fit
13 Floor Est Ocean Centre
No.588 Yanan Rd. East
65 Yanan Rd. West
Shanghai 200001

Tel.: +86 21 6352 8848
Fax: +86 21 6351 3138

Hongkong

Bosch Rexroth (China) Ltd.
6th Floor,
Yeung Yiu Chung No.6 Ind Bldg.
19 Cheung Shun Street
Cheung Sha Wan,
Kowloon, Hongkong

Tel.: +852 22 62 51 00
Fax: +852 27 41 33 44

alexis.siu@boschrexroth.com.hk

India - Indien

Bosch Rexroth (India) Ltd.
Rexroth Indramat Division
Plot. A-58, TTC Industrial Area
Thane Turbhe Midc Road
Mahape Village
Navi Mumbai - 400 701

Tel.: +91 22 7 61 46 22
Fax: +91 22 7 68 15 31

India - Indien

Bosch Rexroth (India) Ltd.
Rexroth Indramat Division
Plot. 96, Phase III
Peenya Industrial Area
Bangalore - 560058

Tel.: +91 80 41 70 211
Fax: +91 80 83 94 345

 mohanvelu.t@boschrexroth.co.in

India - Indien

Bosch Rexroth (India) Ltd.
1st Floor, S-10
Green Park ext. Market
New Delhi – 110016

Tel.: +91 1 16 56 68 88
Fax: +91 1 16 56 68 87

Indonesia - Indonesien

PT. Rexroth Wijayakusuma
Building # 202, Cilandak
Commercial Estate
Jl. Cilandak KKO, Jakarta 12560

Tel.: +62 21 7891169 (5 lines)
Fax: +62 21 7891170 - 71

Japan

Bosch Rexroth Automation Corp.
Service Center Japan
Yutakagaoka 1810, Meito-ku,
NAGOYA 465-0035, Japan

Tel.: +81 52 777 88 41
+81 52 777 88 53
+81 52 777 88 79

Fax: +81 52 777 89 01

Japan

Bosch Rexroth Automation Corp.
Rexroth Indramat Division
1F, I.R. Building
Nakamachidai 4-26-44, Tsuzuki-ku
YOKOHAMA 224-0041, Japan

Tel.: +81 45 942 72 10
Fax: +81 45 942 03 41

Korea

Bosch Rexroth-Korea Ltd.
Electric Drives and Controls
Bongwoo Bldg. 7FL, 31-7, 1Ga
Jangchoong-dong, Jung-gu
Seoul, 100-391

Tel.: +82 234 061 813
Fax: +82 222 641 295

Korea

Bosch Rexroth-Korea Ltd.
1515-14 Dadae-Dong, Saha-Ku
Rexroth Indramat Division
Pusan Metropolitan City, 604-050

Tel.: +82 51 26 00 741
Fax: +82 51 26 00 747
 gyhan@rexrothkorea.co.kr

Malaysia

Bosch Rexroth Sdn.Bhd.
11, Jalan U8/82, Seksyen U8
40150 Shah Alam
Selangor, Malaysia

Tel.: +60  3 78 44 80 00
Fax: +60  3 78 45 48 00
 hockhwa@hotmail.com
 rexroth1@tm.net.my

Singapore - Singapur

Bosch Rexroth Pte Ltd
15D Tuas Road
Singapore 638520

Tel.: +65  68 61 87 33
Fax: +65  68 61 18 25
 sanjay.nemade

@boschrexroth.com.sg

South Africa - Südafrika

TECTRA Automation (Pty) Ltd.
71 Watt Street, Meadowdale
Edenvale 1609

Tel.: +27 11 971 94 00
Fax: +27 11 971 94 40
Hotline: +27 82 903 29 23
 georgv@tectra.co.za

Taiwan

Rexroth Uchida Co., Ltd.
No.17, Alley 24, Lane 737
Cheng Bei 1 Rd., Yungkang
Tainan Hsien

Tel.: +886 6 25 36 565
Fax: +886 6 25 34 754
 indra.charlie@msa.hinet.net

Thailand

NC Advance Technology Co. Ltd.
59/76 Moo 9
Ramintra road 34
Tharang, Bangkhen,
Bangkok 10230

Tel.: +66 2 943 70 62
        +66 2 943 71 21
Fax: +66 2 509 23 62
 sonkawin@hotmail.com



13-6 Service & Support SyConDN

           DOK-CONTRL-SYCON****DN-AW02-EN-P

Nordamerika – North America
USA
Headquarters - Hauptniederlassung

Bosch Rexroth Corporation
Rexroth Indramat Division
5150 Prairie Stone Parkway
Hoffman Estates, IL 60192-3707

Tel.: +1 847 6 45 36 00
Fax: +1 847 6 45 62 01
servicebrc@boschrexroth-us.com
 repairbrc@boschrexroth-us.com

USA Central Region - Mitte

Bosch Rexroth Corporation
Rexroth Indramat Division
Central Region Technical Center
1701 Harmon Road
Auburn Hills, MI 48326

Tel.: +1 248 3 93 33 30
Fax: +1 248 3 93 29 06

USA Southeast Region - Südwest

Bosch Rexroth Corporation
Rexroth Indramat Division
Southeastern Technical Center
3625 Swiftwater Park Drive
Suwanee, Georgia 30124

Tel.: +1 770 9 32 32 00
Fax: +1 770 9 32 19 03

USA SERVICE-HOTLINE

- 7 days x 24hrs -

+1-800-860-1055

USA East Region – Ost

Bosch Rexroth Corporation
Rexroth Indramat Division
Charlotte Regional  Sales Office
14001 South Lakes Drive
Charlotte, North Carolina 28273

Tel.: +1 704 5 83 97 62
+1 704 5 83 14 86

USA Northeast Region – Nordost

Bosch Rexroth Corporation
Rexroth Indramat Division
Northeastern Technical Center
99 Rainbow Road
East Granby, Connecticut 06026

Tel.: +1 860 8 44 83 77
Fax: +1 860 8 44 85 95

USA West Region – West

Bosch Rexroth Corporation
7901 Stoneridge Drive, Suite 220
Pleasant Hill, California 94588

Tel.: +1 925 227 10 84
Fax: +1 925 227 10 81

Canada East - Kanada Ost

Bosch Rexroth Canada Corporation
Burlington Division
3426 Mainway Drive
Burlington, Ontario
Canada L7M 1A8

Tel.: +1 905 335 55 11
Fax: +1 905 335-41 84
 michael.moro@boschrexroth.ca

Canada West - Kanada West

Bosch Rexroth Canada Corporation
5345 Goring St.
Burnaby, British Columbia
Canada V7J 1R1

Tel. +1 604   205-5777
Fax +1 604   205-6944
 david.gunby@boschrexroth.ca

Mexico

Bosch Rexroth Mexico S.A. de C.V.
Calle Neptuno 72
Unidad Ind. Vallejo
07700 Mexico, D.F.

Tel.: +52 5 754 17 11
+52 5 754 36 84
+52 5 754 12 60

Fax: +52 5 754 50 73
+52 5 752 59 43

mariofelipe.hernandez@boschrexroth.com.mx

Mexico

Bosch Rexroth S.A. de C.V.
Calle Argentina No 3913
Fracc. las Torres
64930 Monterrey, N.L.

Tel.: +52 8 333 88 34...36
+52 8 349 80 91...93

Fax: +52 8 346 78 71
mario.quiroga@boschrexroth.com.mx

Südamerika –  South America
Argentina - Argentinien

Bosch Rexroth S.A.I.C.
"The Drive & Control Company"
Acassusso 48 41/47
1605 Munro
Provincia de Buenos Aires

Tel.: +54 11 4756 01 40
Fax: +54 11 4756 01 36
victor.jabif@boschrexroth.com.ar

Argentina - Argentinien

NAKASE
Servicio Tecnico CNC
Calle 49, No. 5764/66
B1653AOX Villa Balester
Provincia de Buenos Aires

Tel.: +54  11 4768 36 43
Fax: +54  11 4768 24 13
 nakase@usa.net
 nakase@nakase.com
 gerencia@nakase.com (Service)

Brazil - Brasilien

Bosch Rexroth Ltda.
Av. Tégula, 888
Ponte Alta, Atibaia SP
CEP 12942-440

Tel.: +55 11  4414 56 92
+55 11  4414 56 84

Fax sales: +55 11  4414 57 07
Fax serv.: +55 11  4414 56 86
 alexandre.wittwer@rexroth.com.br

Brazil - Brasilien

Bosch Rexroth  Ltda.
R. Dr.Humberto Pinheiro Vieira, 100
Distrito Industrial    [Caixa Postal 1273]
89220-390 Joinville - SC

Tel./Fax: +55 47 473 58 33
Mobil: +55 47 9974 6645
 prochnow@zaz.com.br

Columbia - Kolumbien

Reflutec de Colombia Ltda.
Calle 37 No. 22-31
Santafé de Bogotá, D.C.
Colombia

Tel.: +57 1 368 82 67
+57 1 368 02 59

Fax: +57 1 268 97 37
reflutec@neutel.com.co
reflutec@007mundo.com
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